DISCLAIMER

This document contains Honeywell proprietary information. Information contained herein is to be used solely for the purpose submitted, and no part of this document or its contents shall be reproduced, published, or disclosed to a third party without the express permission of Honeywell International Sàrl.

While this information is presented in good faith and believed to be accurate, Honeywell disclaims the implied warranties of merchantability and fitness for a purpose and makes no express warranties except as may be stated in its written agreement with and for its customer.

In no event is Honeywell liable to anyone for any direct, special, or consequential damages. The information and specifications in this document are subject to change without notice.

Copyright 2020- Honeywell International Sàrl
Contents

1 Contents

i About this Guide

Release Information .......................................................... 5
Reference ................................................................. 5
Audience ................................................................. 5
Before You Begin ......................................................... 5
Acronyms and Definitions .............................................. 6

1 Using Standard Workflow Configuration Tool ......................... 7

About Standard Workflow Configuration Tool .................................... 8
Pre-requisites ............................................................. 8
Installing Standard Workflow Configuration Tool ............................. 9
Configuring Workflow ....................................................... 11
User Interface Layout of the Workflow Configuration Tool .................. 11

2 Configuring Workflow for Road Transportation Type ................. 15

Configuring Site-wide Settings ........................................... 16
Configuring Entry Gate Workflow ...................................... 24
Configuring Reporting Office Workflow .................................. 33
Configuring Weighing Area Workflow ................................... 41
Configuring Loading Area Workflow .................................... 49
Configuring Exit Gate Workflow ....................................... 72
Configuring Notification Messages for DIDO and Swing Arm Input .... 78
Configuring Recipes ....................................................... 85
Downloading Density ...................................................... 88
Configurations for card download ....................................... 90
Export Configuration ...................................................... 94
Import Configuration ..................................................... 95
Generating Process Configuration automatically .......................... 96
Scenarios for EXE Generation ........................................... 98
How the EXEs are generated ............................................ 100
Generating Point Files ................................................... 101
Generating Site View Point File ........................................ 101
Generating Bay Allocation Point File ................................... 102
Generating Bay Point File ............................................... 103
Generating BCU Point File ............................................... 105
| CONTENTS |
|-----------------------------------------------|--------|
| Generating DEU Point File                    | 107    |
| Generating Card Reader Point File             | 108    |
| Generating Weighbridge Point File             | 109    |
| Generating ATG Point File                     | 110    |
| Configuring Truck SCADA Attributes            | 111    |
| Configuring Truck SCADA                       | 115    |
| **3 Configuring Workflow for Contrec1010 BI/BJ and Contrec1030 DET** | 121    |
| Configuring Site-wide Settings                | 122    |
| Configure Entry Gate Workflow                 | 128    |
| Configuring Loading Area Workflow             | 131    |
| Configuring Exit Gate Workflow                | 139    |
| **4 Configuring Pipeline Virtual Preset SCADA** | 143    |
| Configuring Pipeline Virtual Preset SCADA Attributes | 144    |
| Configuring Pipeline Virtual Preset           | 148    |
| **5 Configuring Workflow for Marine Transportation Type** | 153    |
| Configuring Marine Site-wide Settings         | 154    |
| Configuring Marine Loading Area Workflow      | 158    |
| Configuring Notification Messages for BCU DIDO and Swing Arm Input | 166    |
| Configuring Recipes                           | 167    |
| Configuring Marine SCADA Attributes           | 168    |
| Configuring Marine SCADA                      | 172    |
| **6 Configuring Workflow for Rail Transportation** | 177    |
| Configuring Rail Site-wide Settings           | 178    |
| Configuring Rail Loading Area Workflow        | 183    |
| Configuring Notification Messages for BCU DIDO and Swing Arm Input | 194    |
| Configuring Recipes                           | 195    |
| Configuring Rail SCADA Attributes             | 196    |
| Configuring Rail SCADA                        | 200    |
| **7 Notices**                                 | 205    |
About this Guide

The Standard Workflow Configuration Tool enables the Project Operations team to configure site-specific workflows, SCADA attributes, and recipes that are within the scope of Terminal Manager R681.1 release.

Note
The Standard Workflow Configuration tool must be removed from the production environment once the required configuration is performed.

Release Information

<table>
<thead>
<tr>
<th>Document Name</th>
<th>Document ID</th>
<th>Release Number</th>
<th>Publication Date</th>
</tr>
</thead>
</table>

Reference

For more information about permissions related to usage of Standard Workflow Configuration Tool, refer to *Terminal Manager Security Guide*.

Audience

This guide is intended for Project Operations team who configure site-specific workflows, SCADA attributes, and recipes that are within the scope of Terminal Manager R681.1 release.

Before You Begin

The users of this guide are expected to have a working knowledge of the Terminal Manager displays and workflows.

If you are a standard model user, you must be familiar with operations of the Web applications. The main interface for this component is through forms in the Web environment.
# Acronyms and Definitions

<table>
<thead>
<tr>
<th>Terminology</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ATG</td>
<td>Automatic Tank Gauging</td>
</tr>
<tr>
<td>BCU</td>
<td>Batch Controller Unit</td>
</tr>
<tr>
<td>BOD</td>
<td>Bill of Discharge</td>
</tr>
<tr>
<td>BOL</td>
<td>Bill of Lading</td>
</tr>
<tr>
<td>DCS</td>
<td>Distributed Control System</td>
</tr>
<tr>
<td>DIDO</td>
<td>Digital Input Digital Output</td>
</tr>
<tr>
<td>FAN</td>
<td>Filling Advisory Note</td>
</tr>
<tr>
<td>FP</td>
<td>Finished Product</td>
</tr>
<tr>
<td>HMI</td>
<td>Human Machine Interface</td>
</tr>
<tr>
<td>PCDET</td>
<td>PC-based touch-enabled Data Entry Terminal</td>
</tr>
<tr>
<td>PIN</td>
<td>Personal Identification Number</td>
</tr>
<tr>
<td>RAN</td>
<td>Receipt Advisory Note</td>
</tr>
<tr>
<td>RFID</td>
<td>Radio-frequency Identification</td>
</tr>
<tr>
<td>RIT</td>
<td>Remote Interface Terminal</td>
</tr>
<tr>
<td>SCADA</td>
<td>Supervisory Control and Data Acquisition</td>
</tr>
</tbody>
</table>
1. Using Standard Workflow Configuration Tool

This chapter describes the configuration of Standard Workflow Configuration Tool required for Terminal Manager application.
1.1 About Standard Workflow Configuration Tool

You can configure the Standard Workflow Configuration Tool to configure site-specific workflow, SCADA attributes, and recipes that are within the scope of Terminal Manager R681.1 release.

**Attention**

- The Standard Workflow Configuration Tool is not part of the standard product installation. You can download this tool from this link.
- You can download the Standard Workflow Configuration Tool User’s guide from this link.

**Note**

To use Standard Workflow Configuration tool, user should have TMAdministrators group and Local Engineers group privileges.

The Standard Workflow Configuration Tool allows you to configure the following:

- Site-wide settings specific to a terminal/site
- Locations
- Failure message configurations related to BCU DI/DOs
- Recipes
- Swing arm inputs
- SCADA attributes for each transportation type
- SCADAs for each transportation type

1.1.1 Pre-requisites

Ensure that you configure the master devices and site view before configuring site-wide settings and workflow.
1.2 Installing Standard Workflow Configuration Tool

You can copy the Standard Workflow Configuration Tool folder consisting the Honeywell.TerminalManager.ConfigureWorkflow.exe.config and Honeywell.TerminalManager.ConfigureWorkflow.exe files provided in the link.

1. Copy the files
   Honeywell.TerminalManager.ConfigureWorkflow.exe.config,
   Honeywell.TerminalManager.ConfigureWorkflow.exe,
   Honeywell.TerminalManager.ConfigureWorkflow.CustomControls.dll,
   and the Resources folder from the above mentioned link to the required Terminal Manager server.

Attention

- Ensure you have “Administrator” and “DBOwner” privileges.
- Administrator with “CoreAdmin” privileges in Terminal Manager can access the Standard Workflow Configuration Tool.
- User with “DBOwner” privileges in database can perform various tasks in the Standard Workflow Configuration Tool.
- If the user does not have the necessary privileges as mentioned above, the Standard Workflow Configuration Tool does not open.
- The application log file is created in a sub-folder named ConfigureWorkflowTool in the installation folder.

2. Right-click Honeywell.TerminalManager.ConfigureWorkflow.exe and select Run as administrator.
The Standard Workflow Configuration Tool window appears as follows.
1.3 Configuring Workflow

1.3.1. User Interface Layout of the Workflow Configuration Tool

The user interface of the Standard Workflow Configuration Tool appears as follows.

The various sections of the Standard Workflow Configuration Tool screen represent the following:

1. The specific configurations at each location, failure message configuration for BCU DI/DO, and so on that can be performed.
   - Click the tab corresponding to the settings you want to configure. For example: If you want to configure workflow for entry gate, click the **Entry Gate** tab.

2. The devices available in the selected location are listed under **Devices** on the left pane.

3. The possible operations that can be carried out at the selected location are listed under **Operations** on the left pane. You can enable or disable these operations. If you disable any of the operations, the particular operation is not performed by the workflow.

4. The mandatory validations that are performed for each operation are listed in the lower half of the page. You cannot edit any of these validations.
You can copy the configurations of one location to another location. For example: If you have configured the settings for the location “EntryGate1” and if you want to replicate the same settings for the location “EntryGate2”, then select the **Copy Configurations from** check box and select “EntryGate1” from the drop-down list.

You can select or configure the validations specific to the selected operation.

The **Save**, **Cancel**, and **Reset** buttons are common to all screens.

- **Save**: The settings configured in the current screen are saved. Ensure that you save the configurations for each screen.

- **Cancel**: To cancel the current settings before saving.

- **Reset**: To restore the default settings.

If you click any other tab without clicking **Save** in the current screen, the settings configured in the current screen are not saved.

If you do not select the correct configurations, a dialog box appears suggesting the appropriate configurations.

For example: If you do not select the **Driver Identification** and **Vehicle Identification** check boxes and select the **Mode of Selection** as **Select From List**.
The following dialog box appears.

![Workflow validation dialog box](image)
This chapter describes the configuration workflow for Road transportation.
2.1 Configuring Site-wide Settings

You can configure the site-wide settings for the entities displayed in the Site Configuration tab.

To configure site-wide settings

1. From the Standard Workflow Configuration Tool window, click on File > Transportation Type > ROAD for configuring road transportation settings.
The configuration window appears:
2 Click the Site Configuration tab.
The following window appears with all the entities listed on the left pane.

3 On the left pane, click Driver under Entities.
The following window appears.
4 Under **Driver**, select the source using which the driver is identified at the terminal. Under **Identification Source**, select one of the following:

- **Access Card**: To identify the driver using an electronic proximity NexWatch access card.
- **PIN**: To identify the driver using a PIN and password. The default value is **PIN**.

5 On the left pane, click **Vehicle** under **Entities**. The following window appears.

6 Under **Vehicle**, select the source using which the vehicle is identified at the terminal. Under **Identification Source**, select one of the following:

- **Access Card**: To identify the vehicle using a NexWatch access card.
- **RFID**: To identify the vehicle using an RFID.
- **PIN**: To identify the vehicle using a PIN. The default value is **PIN**. A password is not required for vehicle identification.

   If you want to create a vehicle dynamically at the entry gate, ensure that you select the **Access Card** option. After you select this option, the Access card to Prime Mover and Trailer section is displayed.

7 Under **Access card to Prime Mover and Trailer**, select **Yes** if you want to validate the access cards of prime mover and trailer before creating a vehicle dynamically; else, select **No**. The access cards of the prime mover and trailer selected for creating a vehicle are validated at the entry gate.
On the left pane, click **Reports** under **Entities**. The following window appears.

![Image](image_url)

Under **Reports**, enter the following information:

- In the **FAN Report (Volume)** box, type the Filling Advisory Note (FAN) report name for volume-based shipments.
  - The default FAN report name for volume-based shipments is **FANReportVolume**.
- In the **FAN Report (Weight)** box, type the FAN report name for weight-based shipments.
  - The default FAN report name for weight-based shipments is **FANReportWeight**.
- In the **BOL Report** box, type the Bill of Lading (BOL) report name.
  - The default BOL report name for shipments is **TMBOL**.
- In the **RAN Report (Volume)** box, type the Receipt Advisory Note (RAN) report name for volume-based receipts.
  - The default RAN report name for volume-based receipts is **RANReportVolume**.
- In the **RAN Report (Weight)** box, type the RAN report name for weight-based receipts.
The default RAN report name for weight-based receipts is **RANReportWeight**.

- In the **BOD Report** box, type the Bill of Discharge (BOD) report name. The default BOD report name for receipts is **TMBOD**.
- In the **Copies** list, type or select the number of copies to be printed for each report.

---

**Note**

When you print a report from Terminal Manager, the number of copies of the report printed on each printer is based on the value selected in the Copies list. If multiple printers are configured for each report, the configured number of copies is printed on each printer.

---

10 On the left pane, click **Shipment** under **Entities**. The following window appears.

![Image of Standard Workflow Configuration Tool](image)

11 Under **Shipment**, select one of the following based on the maximum number of characters of finished product code that can be displayed on the BCU:

- **Product Code**: To display the finished product code on the BCU.
- **Product Index**: To display the finished product index on the BCU. The default value is **Product Code**.
12 On the left pane, click **Language** under **Entities**. The following window appears.

13 Under **Language**, perform the following:

- From the **BCU** drop-down list, select the language in which the messages must be displayed on the BCU. For example: Select **en-US** to view the BCU messages in US English.

**Note**

- Ensure that the firmware supports language customization.
- If you want to select any other language, ensure that you first configure the required language in the **Language** page in Terminal Manager. The configured language is displayed in these drop-down lists.

- From the **Touch Screen** drop-down list, select the language in which the messages must be displayed on the PCDET. For example: Select **en-US** to view the PCDET messages in US English. The default value is **en-US**.
14 On the left pane, click **General** under **Entities**. The following window appears.

15 In the **SCADA Server Base Name** box, type the base name of the SCADA server. During installation, this name is updated by default. However, you can update this name if required.

16 Select the **Tare Weight and Laden Weight to be measured on same weighbridge** check box, if you want to measure the tare weight and laden weight of a vehicle at the same weighbridge. If the weighbridge used to measure the tare weight is not operational due to some issues (repair mode, communication issue, and so on), then measure the laden weight at any other weighbridge.

17 Click **Save**.
The site-wide configuration is complete.
2.2 Configuring Entry Gate Workflow

An entry gate is a physical barrier that must be crossed in order to enter the terminal. Typically, an entry gate may involve a workflow which validates the driver, vehicle, and/or shipment. You can also perform a compartment planning for a shipment.

You can configure the workflow for the entry gate. Based on the configurations, the entry gate workflow or the PCDET performs the operations such as driver, vehicle, and/or shipment identification. The possible devices at this location are card reader, PCDET, and weighbridge.

To configure entry gate workflow

1. From the Standard Workflow Configuration Tool window, click the Entry Gate tab. The entry gate window appears.

2. From the Entry Gate drop-down list, select the entry gate for which you want to configure various activities. The entry gates configured in the Site View Configuration page are listed. For example: EntryGate1.

   The following window appears.


   The Driver Identification check box is selected by default for an entry gate. The entry gate workflow or the PCDET prompts for driver identification.
through access card or PIN- password, as per the site-wide configuration. After clicking **Driver Identification**, the following window appears.

![Image](image.png)

4 Under **Driver Validations**, select the **License 2 Expiry Required** check box, if you want to validate the driver based on the expiry date of the driver’s second license. The validations that are mandatorily verified as a part of the standard product such as whether the driver is valid, shareholder is active, and so on, are displayed on the lower half of the page.

5 Under **Operations**, click **Vehicle Identification**.
   The **Vehicle Identification** check box is selected by default. The entry gate workflow or the PCDET prompts for vehicle identification through access card or PIN, as per the site-wide configuration.
After you click **Vehicle Identification**, the following window appears.

![Image of Vehicle Identification window](image)

6 Under **Vehicle Validation**, perform the following:

- Select the **Record Tare Weight** check box, if you want to weigh the tare weight of the vehicle at the entry gate.

- Select the **Record Truck Receipt Laden Weight** check box, if you want to weigh the laden weight of the vehicle at the entry gate for truck receipts.

- Select the **Dynamic Vehicle Creation** check box to create vehicles dynamically at the entry gate. Ensure that you always select this check box.

- Select the **HSE Inspection** check box, to validate the respective workflow for HSE Inspection.

**Attention**

To record the tare weight and/or laden weight of a vehicle, the **Vehicle Identification** operation is mandatory.

7 Under **Operations**, click **Shipment Identification**. The **Shipment Identification** check box is selected by default. The entry gate workflow or the PCDET prompts for shipment selection and/or confirmation, as per the shipment validation configurations.
After you click **Shipment Identification**, the following window appears.

![Image](image-url)

**Attention**

If you have not selected **Vehicle Identification** and/or **Driver Identification** check boxes under **Operations**, ensure that you select only the following options.

- **Shipment By Product** and/or **Shipment By Compartment** for **Shipment Source Selection**.
- **Enter Shipment Code** for **Mode of Selection**.

This is applicable to all locations where the shipment identification operation has the option of selecting shipment.

8 Under **Shipment Source Selection**, you can select the source to view or create a shipment. Select any of the following:

- Select the **Order** check box, if you want to create shipments from an order, at the entry gate.
- Select the **Contract** check box, if you want to create shipments from a contract, at the entry gate.
- Select the **Shipment By Product** check box, if you want to view shipment by product, at the entry gate.
- Select the **Shipment By Compartment** check box, if you want to view the shipments available for the identified vehicle and/or driver at the entry gate.
gate, and also view the compartment plan for the already created shipment. If multiple sources are selected, the PCDET prompts the driver to select the option for viewing or creating the shipment.

For example: If you select the **Order, Contract, and Shipment By Product** check boxes, the driver can create a shipment from contract or order, or view a list of shipment by products for the identified vehicle, in the PCDET at the EntryGate1.

The default values for shipment source are **Shipment By Product** and **Shipment By Compartment**.

9 If you have selected shipment by product or compartment as the source for shipment selection, then you can choose any one of the following under **Mode of Selection**.

- **Enter Shipment Code**: The driver must enter the shipment code to select the shipment.
- **Confirmed Shipment**: The driver must confirm the shipment for the identified vehicle and/or driver.
- **Select From List**: The driver can select a shipment from a list of shipments available for the identified vehicle and/or driver, within the configured date range.

The default value is **Select From List**.

10 Under **Shipment Input Status**, select the statuses of the shipments, based on which the driver can view the shipments.

For example: If the input status is selected as **READY** and **CHECKED_IN**, the driver can view or select only the shipments that are in **READY** or **CHECKED_IN** statuses.

The default shipment input status is **READY**.

11 Under **Shipment Output Status**, select the status to which the shipment must be updated by the entry gate workflow, after all entry gate operations are performed.

For example: If the output status is selected as **QUEUED**, the status of the selected shipment is updated to **QUEUED**, after all entry gate operations are performed.

The default shipment input status is **CHECKED_IN**.

---

**Note**

- Based on project requirements, if some custom states are planned, then these custom statuses must be between **READY** and **CLOSED**. You must configure the appropriate shipment input and output statuses considering these custom statuses.
- A shipment can have multiple input statuses. However, the shipment can have only one output status. This applies to all the input and output statuses of shipment.
12 Select the **Bay Allocation Required** check box, if you want to allocate bays to the shipments at the entry gate. If this check box is selected, bays are automatically allocated to the selected shipment at the entry gate, only if the automatic bay allocation service is configured to run at this site.

13 Select the **Print FAN** check box, if the FAN report must be printed at this location.

The **Print FAN** check box is selected by default.

The validations that are mandatorily verified as a part of the standard product such as whether the shipment is valid, shipment is active, and so on, are displayed on the lower half of the page.

14 Under **Operations**, click **Shipment Validations**.

The **Shipment Validations** check box is selected by default, and is unavailable for editing.

After you click **Shipment Validations**, the following window appears.

![Shipment Validations Window](image)

15 Under **Shipment Validations**, perform the following:

- Select the **Driver - Vehicle belong to same carrier** check box, if the workflow must validate whether both the driver and vehicle belong to the same carrier company.

- Select the **Schedule date valid** check box, if you want to specify the duration for which the shipment can be viewed or selected by the driver at this entry gate.

  If you select the check box, the **Date Range (+/-) days** box is available for editing. Type a value determining the range for which the shipment is
valid.
For example: If the value for the field **Date Range (+/-) days** is set to 2 and if the scheduled date is January 10, the driver can view or select the shipments that are scheduled between January 8th (two days earlier than the scheduled date) and January 12th (two days later than the scheduled date).

16 Under **Operations**, click **Truck Receipt Identification**. The **Truck Receipt Identification** check box is selected by default. The entry gate workflow or the PCDET prompts for receipt selection and/or confirmation, as per the receipt validation configurations.
After you click **Truck Receipt Identification**, the following window appears.

![Standard WorkFlow Configuration Tool](image)

**Attention**
If you have not selected **Vehicle Identification** and/or **Driver Identification** check boxes under Operations, ensure that you select only the **Enter Receipt Code** option for **Mode of Selection**.
This is applicable to all locations where the receipt identification operation has the option of selecting receipt.

Under **Receipt Source Selection**, select the **Receipt By Compartment** check box if you want to view receipts available for the identified vehicle and/or
driver at the entry gate, and also view the compartment plan for the already created receipt.

17 Under **Mode of Selection**, choose any one of the following:

- **Enter Receipt Code**: The driver must enter the receipt code to select the receipt.
- **Confirmed Receipt**: The driver must confirm the receipt for the identified driver and/or vehicle.
- **Select From List**: The driver can select a receipt from a list of receipts available for the identified vehicle and/or driver, within the configured date range.

The default value is **Select From List**.

18 Under **Receipt Input Status**, select the statuses of the receipts, based on which the driver can view the receipts. For example: If the input status is selected as **READY** and **CHECKED_IN**, the driver can view or select only the receipts that are in **READY** or **CHECKED_IN** statuses.

The default receipt input status is **READY**.

### Note

- Based on project requirements, if some custom states are planned, then these custom statuses must be between **READY** and **CLOSED**. You must configure the appropriate receipt input and output statuses considering these custom statuses.
- A receipt can have multiple input statuses. However, the receipt can have only one output status. This applies to all the input and output statuses of receipt.

19 Under **Receipt Output Status**, select the status to which the receipt must be updated by the entry gate workflow, after all entry gate operations are performed. For example: If the output status is selected as **QUEUED**, the status of the selected receipt is updated to **QUEUED**, after all entry gate operations are performed.

The default receipt output status is **CHECKED_IN**.

20 Select the **Bay Allocation Required** check box, if you want to allocate bays to the receipts at the entry gate. If this check box is selected, bays are automatically allocated to the selected receipt at the entry gate, only if the automatic bay allocation service is configured to run at this site.

21 Select the **Print RAN** check box, if the RAN report must be printed at this location. The **Print RAN** check box is selected by default.

The validations that are mandatorily verified as a part of the standard product
such as whether the receipt is valid, receipt is active, and so on, are displayed on the lower half of the page.

22 Under **Operations**, click **Truck Receipt Validation**.
   The **Truck Receipt Validation** check box is selected by default, and is unavailable for editing.
   After you click **Truck Receipt Validation**, the following window appears.

![Window showing Truck Receipt Validation options](image)

23 Under **Receipt Validations**, perform the following:

- Select the **Driver - Vehicle belong to same carrier** check box, if the workflow must validate whether both the driver and vehicle belong to the same carrier company.

- Select the **Schedule date valid** check box, if you want to specify the duration for which the receipt can be viewed or selected by the driver at this entry gate.
   If you select the check box, the **Date range (+/ -) days** box is available for editing. Type a value determining the range for which the receipt is valid.
   For example: If the value for the field **Date range (+/ -) days** is set to 2 and if the scheduled date is January 10, the driver can view or select the receipts that are scheduled between January 8th (two days earlier than the scheduled date) and January 12th (two days later than the scheduled date).

24 Click **Save**.
   The entry gate workflow configuration is complete.
2.3 Configuring Reporting Office Workflow

A reporting office is a location in a terminal where certain administration activities are carried out. For example: If the site has the concept of issuing temporary cards associated to shipments, the driver can approach the reporting office to get a temporary card issued for the shipment. Based on the site practice, the reporting office can also be used as a location where bays are manually allocated, FAN and commercial invoices are printed, and so on.

You can configure various activities for the reporting office, as per the requirement. The possible device at this location is card reader.

To configure reporting office workflow

1. From the Standard Workflow Configuration Tool window, click the Reporting Office tab.
   The reporting office window appears.

2. From the Reporting Office drop-down list, select the reporting office for which you want to configure various activities.
   The reporting offices configured in the Site View Configuration page are listed.
   For example: ReportingOffice1.
   The following window appears.

   The Driver Identification check box is selected by default for a reporting
office. When a shipment or receipt is authorized to load or unload respectively using Terminal Manager, driver validations are performed as per the workflow configuration.
After you click **Driver Identification**, the following window appears.

![Driver Identification Window](image)

4 Under **Driver Validations**, select the **License 2 Expiry Required** check box, if you want to validate the driver based on the expiry date of the driver’s second license. The validations that are mandatorily verified as a part of the standard product such as, whether the driver is valid, shareholder is active, and so on, are displayed on the lower half of the page.
5 Under **Operations**, click **Vehicle Identification**. The **Vehicle Identification** check box is selected by default.

6 Under **Vehicle Validation**, perform the following:
   - Select the **Record Tare Weight** check box, if you want to record the tare weight of the vehicle at the reporting office for the selected shipment.
   - Select the **Record Truck Receipt Laden Weight** check box, if you want to record the laden weight of the vehicle at the reporting office for the selected receipt.

   **Attention**
   To record the tare weight and/or laden weight of a vehicle, the **Vehicle Identification** operation is mandatory.

   - Select the **Dynamic Vehicle Creation** check box, to create vehicles dynamically at the reporting office. Ensure that you always select this check box.
7 Under **Operations**, click **Shipment Identification**. The **Shipment Identification** check box is selected by default. After you click **Shipment Identification**, the following window appears.

8 Under **Shipment Input Status**, select the statuses of the shipments, based on which the driver can view the shipments. For example: If the input state is selected as **READY**, then only the shipments that are in **READY** states can be authorized to load. The default shipment input state is **READY**.

9 Under **Shipment Output Status**, select the status to which the shipment must be updated by the entry gate workflow, after all entry gate operations are performed. For example: If the output state is selected as **CHECKED_IN**, the status of the selected shipment is updated to **CHECKED_IN**, after a shipment loading is authorized. The default shipment output state is **CHECKED_IN**.

**Note**

- Based on project requirements, if some custom states are planned, then these custom statuses must be between **READY** and **CLOSED**. You must configure the appropriate shipment input and output statuses considering these custom statuses.
- A shipment can have multiple input statuses. However, the shipment can have only one output status. This applies to all the input and output statuses of shipment.
10 Under **Operations**, click **Shipment Validation**. The **Shipment Validation** check box, is selected by default and is unavailable for editing. After you click **Shipment Validation**, the following window appears.

![Shipment Validation Window](image)

11 Under **Shipment Validations**, perform the following:

a. Select the **Driver - Vehicle belong to same carrier** check box, if the driver and the vehicle for a shipment must belong to the same carrier company.

b. Select the **Schedule date valid** check box, if you want to specify the duration for which the shipment can be viewed or selected by the driver at this reporting office. If you select the check box, the **Date range (+/ -) days** box is available for editing. Type a value determining the range for which the shipment is valid.

For example: If the value for the field **Date range (+/ -) days** is set to 2 and if the scheduled date is January 10, the driver can view or select the shipments that are scheduled between January 8th (two days earlier than the scheduled date) and January 12th (two days later than the scheduled date).

12 Under **Operations**, click **Truck Receipt Identification**. The **Truck Receipt Identification** check box is selected by default.
13 After you click **Truck Receipt Identification**, the following window appears.

![Truck Receipt Identification Window](image)

**Attention**

If you have not selected **Vehicle Identification** and/or **Driver Identification** check boxes under **Operations**, ensure that you select only the **Enter Receipt Code** option for **Mode of Selection**.

This is applicable to all locations where the receipt identification operation has the option of selecting receipt.

14 Under **Receipt Input Status**, select the statuses of the receipts, based on which the driver can view the receipts.

For example: If the input status is selected as **READY** and **CHECKED_IN**, the driver can view or select only the receipts that are in **READY** or **CHECKED_IN** statuses.

The default receipt input status is **READY**.

15 Under **Receipt Output Status**, select the status to which the receipt must be updated by the entry gate workflow, after all entry gate operations are performed.

For example: If the output status is selected as **QUEUED**, the status of the selected receipt is updated to **QUEUED**, after all entry gate operations are performed.
The default receipt output status is **CHECKED_IN**.

**Note**

- Based on project requirements, if some custom states are planned, then these custom statuses must be between **READY** and **CLOSED**. You must configure the appropriate receipt input and output statuses considering these custom statuses.
- A receipt can have multiple input statuses. However, the receipt can have only one output status. This applies to all the input and output statuses of receipt.

The validations that are mandatorily verified as a part of the standard product such as whether the receipt is valid, receipt is active, and so on, are displayed on the lower half of the page.

16 **Under Operations**, click **Truck Receipt Validation**. The **Truck Receipt Validation** check box is selected by default, and is unavailable for editing.

After you click **Truck Receipt Validation**, the following window appears.
17 Under **Receipt Validations**, perform the following:

- Select the **Driver - Vehicle belong to same carrier** check box, if the workflow must validate whether both the driver and vehicle belong to the same carrier company.

- Select the **Schedule date valid** check box, if you want to specify the duration for which the receipt can be viewed or selected by the driver at this reporting office.

  If you select the check box, the **Date range (+/-) days** box is available for editing. Type a value determining the range for which the receipt is valid. For example: If the value for the field **Date range (+/-) days** is set to 2 and if the scheduled date is January 10, the driver can view or select the receipts that are scheduled between January 8th (two days earlier than the scheduled date) and January 12th (two days later than the scheduled date).

18 Click **Save**.

The reporting office workflow configuration is complete.
2.4 Configuring Weighing Area Workflow

A weighing area is an intermediate location between the entry and loading area. It is a location where the weighbridge is located. The weighbridge may be used to measure the tare weight of the vehicle before loading. The operations at the weighing area are similar to that of the entry gate. In sites where a weighbridge is used for weighing both tare weight and laden weight, a weighing area and an exit gate must be created with same set of devices.

You can configure the workflow for the weighing area. The possible devices available at this location are card reader, PCDET, and weighbridge.

To configure weighing area workflow

1. From the **Standard Workflow Configuration Tool** window, click the **Weighing Area** tab.
   The weighing area window appears.

2. From the **Weighing Area** drop-down list, select the weighing area for which you want to configure various activities.
   The weighing areas configured in the **Site View Configuration** page are listed.
   For example: WeighingArea1.
   The following window appears.

3. Under **Operations**, click **Driver Identification**.
   The **Driver Identification** check box is selected by default for a weighing
area. The PCDET prompts for driver identification through access card or PIN-password, as per the site-wide configuration. After you click **Driver Identification**, the following window appears.

![Driver Identification Window](image)

4 Under **Driver Validations**, select the **License 2 Expiry Required** check box, if you want to validate the driver based on the expiry date of the driver’s second license.

The mandatory validations such as whether the driver is valid, shareholder is active, and so on, are listed on the lower half of the page.

5 Under **Operations**, click **Vehicle Identification**. The **Vehicle Identification** check box is selected by default. The PCDET prompts for vehicle identification through access card or PIN, as per the site-wide configuration.
After you click **Vehicle Identification**, the following window appears.

![Configuration Workflow Window](image)

6 Under **Entry Weighing Area** Validation, perform the following:

- Select the **Record Tare Weight** check box, if you want to record the tare weight of the vehicle at the entry weighing area for the selected shipment.

- Select the **Record Truck Receipt Laden Weight** check box, if you want to record the laden weight of the vehicle at the entry weighing area for the selected receipt.

**Attention**

To record the tare weight and/or laden weight of a vehicle, the **Vehicle Identification** operation is mandatory.
7 Under **Exit Weighing Area** Validation, perform the following:

- Select the **Record Laden Weight** check box, if you want to record the laden weight of the vehicle at the exit weighing area for the selected shipment.
- Select the **Record Truck Receipt Tare Weight** check box, if you want to record the tare weight of the vehicle at the exit weighing area for the selected receipt.

8 Under **Operations**, click **Shipment Identification**.
   The **Shipment Identification** check box is selected by default. The PCDET prompts for shipment selection and/or confirmation, as per the shipment validation configurations.
   After you click **Shipment Identification**, the following window appears.

9 Under **Mode of Selection**, select any of the following:

- **Enter Shipment Code**: The driver must enter the shipment code to select the shipment.
- **Confirmed Shipment**: The driver must confirm the shipment for the identified vehicle and/or driver.
   The default value for shipment selection is **Enter Shipment Code**.
10 Under **Shipment Input Status**, select the statuses of the shipments, based on which the shipment loading can be authorized. For example: If the input status is selected as **CHECKED_IN**, only the shipments that are in **CHECKED_IN** statuses can be authorized to load. The default shipment input statuses are **READY** and **CHECKED_IN**.

11 Under **Shipment Output Status**, select the status to which the shipment must be updated, after the shipment loading is authorized. For example: If the output status is selected as **WEIGHED_IN**, the status of the selected shipment is updated to **WEIGHED_IN**, after the shipment loading is authorized. The default shipment output status is **WEIGHED_IN**.

12 Select the **Bay Allocation Required** check box, if you want to allocate bays to the shipments at the entry weighing area. If this check box is selected, bays are automatically allocated to the selected shipment at the weighing area.

13 Select the **Bay Deallocation Required** check box if you want to release the bays allocated for the current shipment at the weighing area. If this check box is selected, bays are automatically released from the selected shipment at the weighing area.

14 Under **Operations**, click **Shipment Validation**. The following window appears.
15 Under **Shipment Validations**, perform the following:

- Select the **Driver - Vehicle belong to same carrier** check box, if the driver and the vehicle for a shipment belong to the same carrier company.

- Select the **Schedule date valid** check box, if you want to specify the duration for which the shipment can be viewed or selected by the driver at this weighing area.

  If you select the check box, the **Date range (+/-) days** box is available for editing. Type a value determining the range for which the shipment is valid.

  For example: If the value for the field **Date range (+/-) days** is set to 2 and if the scheduled date is January 10, the driver can view or select the shipments that are scheduled between January 8th (two days earlier than the scheduled date) and January 12th (two days later than the scheduled date).

16 Under **Operations**, click **Truck Receipt Identification**.

The **Truck Receipt Identification** check box is selected by default. The PCDET prompts for receipt selection and/or confirmation, as per the receipt validation configurations.

After you click **Truck Receipt Identification**, the following window appears.
17 Under **Mode of Selection**, select any of the following:

- **Enter Receipt Code**: The driver must enter the receipt code to select the receipt.
- **Confirmed Receipt**: The driver must confirm the receipt for the identified vehicle and/or driver.

The default value for receipt selection is **Enter Receipt Code**.

18 Under **Receipt Input Status**, select the statuses of the receipts, based on which the receipt loading can be authorized. For example: If the input status is selected as **CHECKED_IN**, only the receipts that are in **CHECKED_IN** statuses can be authorized to load. The default receipt input statuses are **READY** and **CHECKED_IN**.

19 Under **Receipt Output Status**, select the status to which the receipt must be updated, after the loading for a receipt is authorized. For example: If the output status is selected as **WEIGHED_IN**, the status of the selected receipt is updated to **WEIGHED_IN**, after the receipt loading is authorized. The default receipt output status is **WEIGHED_IN**.

20 Select the **Bay Allocation Required** check box, if you want to allocate bays to the receipts at the entry weighing area. If this check box is selected, bays are automatically allocated to the selected receipt at the weighing area.

21 Select the **Bay Deallocation Required** check box, if you want to release the bays allocated for the current receipt at the weighing area. If this check box is selected, bays are automatically released from the selected receipt at the weighing area.

22 Under **Operations**, click **Truck Receipt Validation**. The **Truck Receipt Validation** check box is selected by default and is unavailable for editing.
After you click **Truck Receipt Validation**, the following window appears.

23 Under **Receipt Validations**, perform the following:

- Select the **Driver - Vehicle belong to same carrier** check box, if the workflow must validate whether both the driver and vehicle belong to the same carrier company.

- Select the **Schedule date valid** check box, if you want to specify the duration for which the receipt can be viewed or selected by the driver at this entry gate.

  If you select the check box, the **Date range (+/-) days** box is available for editing. Type a value determining the range for which the receipt is valid. For example: If the value for the field **Date range (+/-) days** is set to 2 and if the scheduled date is January 10, the driver can view or select the receipts that are scheduled between January 8th (two days earlier than the scheduled date) and January 12th (two days later than the scheduled date).

24 Click **Save**.

The weighing area workflow configuration is complete.
2.5 Configuring Loading Area Workflow

A bay is a location where loading and/or unloading operations happen in the terminal.

The terms bay and loading area refers to the same location. The loading area is represented as bay throughout the document.

You must configure the workflow for each bay. The possible devices available at the bay are the BCU and card reader. The BCU itself is used as a HMI. Therefore, a PCDET is not supported in this location.

To configure bay workflow

1. From the Standard Workflow Configuration Tool window, click the Loading Area tab.
   The loading area window appears.

2. From the Loading Area drop-down list, select the bay for which you want to configure various activities.
   The bays configured in the Site View Configuration page are listed.
   For example: Bay1_Gasoline.
   The following window appears.

   The Driver Identification check box is selected by default for a bay. The BCU prompts for driver identification through access card or PIN- password, as per the site-wide configuration.
After you click **Driver Identification**, the following window appears.

4 Under **Driver Validations**, select the **License 2 Expiry Required** check box, if you want to validate the driver based on the expiry date of the driver’s second license. The mandatory validations such as whether the driver is valid, shareholder is active, and so on, are displayed on the lower half of the page.

5 Under **Operations**, click **Vehicle Identification**. The **Vehicle Identification** check box is selected by default.
After you click **Vehicle Identification**, the following window appears.

![Vehicle Identification Window](image)

6 Under **Vehicle Validation**, perform the following:

- Select the **Record Tare Weight** check box, if you want to weigh the tare weight of the vehicle at the entry gate.
- Select the **Record Truck Receipt Laden Weight** check box, if you want to weigh the laden weight of the vehicle at the entry gate for truck receipts.
- Select the **Dynamic Vehicle Creation** check box to create vehicles dynamically at the entry gate. Ensure that you always select this check box.

---

**Attention**

To record the tare weight and/or laden weight of a vehicle, the **Vehicle Identification** operation is mandatory.

---

7 Under **Operations**, click **Shipment Identification**.

The **Shipment Identification** check box is selected by default. The workflow prompts for shipment selection and/or confirmation, as per the shipment validation configurations.
After you click **Shipment Identification**, the following window appears.

![Shipment Identification Window](image.png)

8 Under **Shipment Source Selection**, select the source to view or to create a shipment. Select any of the following:

   a. Select the **Order** check box, if you want to create shipments from an order, at the bay.

   b. Select the **Contract** check box, if you want to create shipments from a contract, at the bay.

   c. Select the **Shipment By Product** check box, if you want to view a list of shipment by products for the identified vehicle, in the BCU at this bay.

   d. Select the **Shipment By Compartment** check box, if you want to view the shipments available for the identified vehicle and/or driver, at the bay.

If multiple sources are selected, the workflow prompts the driver to select the option for viewing or creating the shipment.

For example: If you select the **Order, Contract, and Shipment By Product** check boxes, the driver can create shipment from contract or order, or view a list of shipment by products for the identified vehicle, in the BCU at this bay.

The default values for shipment source are **Shipment by Product** and **Shipment By Compartment**.
9 If you have selected shipment by product or compartment as the source for shipment selection, then choose any one of the following under Mode of Selection.
   a. Enter Shipment Code: The driver must enter the shipment code to select the shipment.
   b. Confirmed Shipment: The driver must confirm the shipment for the identified vehicle.
   c. Select From List: The driver can select a shipment from a list of shipments available for the identified vehicle and/or driver within the configured date range.

10 Under Shipment Input Status, select the statuses of the shipments, based on which the driver can view the shipments.
   The default shipment input statuses are CHECKED_IN and PARTIALLY_LOADED.

11 Under Bay Allocation, select any one of the following:
   a. Enforce: The workflow validates whether the selected shipment is allocated to the current bay and is in the loading position. If this condition fails, then the shipment is not authorized in the particular bay and appropriate notifications are raised.
   b. Check: The workflow validates whether the selected shipment is recommended to the current bay. If this condition fails, then a notification is raised indicating that the shipment has come for loading at a bay that is not the recommended bay. However, the shipment is authorized to load in the particular bay.
   c. None: The workflow does not carry out any validations related to shipment bay allocation.

Note
Set the value of Bay Allocation option to None if the shipment source selection is either from order or from contract, and if the shipment is being created for a vehicle in the bay for the first time.
If driver and vehicle identification is disabled, then a shipment or receipt must always be created by the primary shareholder, for the loading/unloading operations to happen using the Terminal Manager Workflow.

12 Under Operations, click Shipment Validations.
   The Shipment Validations check box, is selected by default and is unavailable for editing.
After you click **Shipment Validations**, the following window appears.

![Shipment Validations Window](image)

13 Under **Shipment Validations**, perform the following:

a. Select the **Driver - Vehicle belongs to same carrier** check box, if the driver and the vehicle for a shipment must belong to the same carrier company.

b. Select the **Schedule date valid** check box, if you want to specify the duration for which the shipment can be viewed or selected by the driver at this bay.

   If you select the check box, the **Date range (+/ -) days** box is available for editing. Type a value determining the range for which the shipment is valid.

   For example: If the value for the field **Date range (+/ -) days** is set to 2 and if the scheduled date is January 10, the driver can view or select the shipments that are scheduled between January 8th (two days earlier than the scheduled date) and January 12th (two days later than the scheduled date).

14 Under **Operations**, click **Shipment Close**. You can select this option when there is no exit gate in the terminal, and the shipment must be closed automatically by the workflow on successful loading as per the shipment plan.
The following window appears.

![Configuration Window](image)

15 Under **Report Options**, select the **Print BOL** check box, if you want to print a Bill of Lading (BOL) report after a shipment is successfully loaded at the bay.

16 Under **Bay Allocation Option**, select the **Bay DeAllocation Required** check box, if you want to release the bay allocated for the current shipment.

17 Under **Operations**, click **Compartment Plan**.
The following window appears.

![Standard Workflow Configuration Tool](image)

18 Under **Compartment Plan Options**, perform the following:

a. Select the **Return Quantity** check box, if you want the workflow to prompt for the return quantity in the vehicle’s compartments.

b. Select the **Remote Start** check box, if the loading must be started from the control room and not from the BCU Start button.

c. Select the **Download Density** check box, if the density value can be downloaded to the BCU.

d. Select the **Check Tank LineUp** check box, if you want to check the tanks lined up for the selected shipment.

e. Select the **Confirm Preset Quantity** check box, if the driver wants to confirm the preset quantity.

f. Select the **Change Preset Quantity** check box, if the driver wants to change the preset quantity. For example: If the preset quantity is 2000 liters and if the driver wants to load 1500 liters, then the driver can change the quantity.
19 Under **Loading Arm Options**, select one of the following:

a. **Change Loading Arm** option if you want to change the loading arm number.

b. **Confirm Loading Arm** option if you want to confirm the selected arm for loading.

20 Under **Compartment Selection Options**, perform the following:

a. Select the **Change Compartment Number** check box if the driver wants to change the compartment number in which the product must be loaded.

b. Select the **Confirm Compartment Number** check box if the driver wants to confirm the compartment number.

21 Under **Operations**, click **Monitor Loading**.

If the BCU configured in the bay is Accuload-III, Accuload-IV, Contrec 1010CB, or Contrec 1010CJ, the following window appears.

---

**Note**

- If **Change Preset Quantity** is selected on WCT for SBP/Order/Contract, then workflow prompts for entering the preset quantity.
- If **Confirm Preset Quantity** is selected on WCT for SBP/Order/Contract, then workflow prompts for confirming the minimum of remaining quantity or SFL. If the prompt is not confirmed for the quantity, then **Enter Preset Quantity** prompt is shown, so that any lesser quantity can be planned for the compartment.
If the BCU configured in the bay is “MSC-L”, then the following window appears.

![Workflow Configuration Tool](image)

22 Under **Monitor Load Options**, the following check boxes are selected by default.

   a. **Flow Rate**: To monitor the flow rate of the product during loading.
   b. **Temperature**: To monitor the temperature of the product during loading.
   c. **Density**: To monitor the density of the product during loading.
   d. **Pressure**: To monitor the pressure of the product during loading.
   e. **Mass**: To monitor the mass of the product during loading.
   f. **Totalizer**: To monitor the totalizer value during loading.


24 For MSC-L BCU, select any or all of the following check boxes:

   - **CAN-IN-OUT-MSC Board 1**: To monitor the DIDO configurations for the following points: DI_DC_1 till DI_DC_15, DI_AC_1 till DI_AC_3, DO_EMR_1 till DO_EMR_10, DO_SSR_13 till DO_SSR_16
   - **CAN-IN-OUT-MSC Board 2**: To monitor the DIDO configurations for the following points: DI_DC_16 till DI_DC_30, DI_AC_4 till DI_AC_6, DO_EMR_11 till DO_EMR_20, DO_SSR_17 till DO_SSR_20
• **CAN-IN-OUT-MSC Board 3**: To monitor the DIDO configurations for the following points: DI_DC_31 till DI_DC_45, DI_AC_7 till DI_AC_9, DO_EMR_21 till DO_EMR_30, DO_SSR_33 till DO_SSR_36

• **CAN-IN-OUT-MSC Board 4**: To monitor the DIDO configurations for the following points: DI_DC_46 till DI_DC_60, DI_AC_10 till DI_AC_12, DO_EMR_31 till DO_EMR_40, DO_SSR_37 till DO_SSR_40

• **CAN-ARM-MSC Board 1**: To monitor the DIDO configurations for the following points: DO_SSR_1 till DO_SSR_12

• **CAN-ARM-MSC Board 2**: To monitor the DIDO configurations for the following points: DO_SSR_21 till DO_SSR_32

If you do not want to monitor any or all of these details, you can clear any or all of these check boxes.

25 Under **Operations**, click **Leakage**. The following window appears

26 Select the **Before Loading** check box, to capture the leakage details of the loading arm, before the loading of product begins.

27 Under **Operations**, select the **Local Loading** check box, if you want to upload the locally loaded transaction details to the Terminal Manager database.
28 Under **Operations**, click **Truck Receipt Identification**. The **Truck Receipt Identification** check box is selected by default. The workflow prompts for receipt selection and/or confirmation, as per the receipt validation configurations. After you click **Truck Receipt Identification**, the following window appears.

![Image](image.png)

29 Under **Receipt Source Selection**, select the **Receipt by Compartment** check box if you want to view receipts available for the identified vehicle and/or driver, at the bay.

30 Under **Mode of Selection**, choose any one of the following:

a. **Enter Receipt Code**: The driver must enter the receipt code to select the receipt.

b. **Confirmed Receipt**: The driver must confirm the receipt for the identified vehicle and/or driver.

**Note**

Ensure that you do not select the **Truck Receipt Identification** and **Truck Receipt Validation** check boxes and skip steps 27 to 41 for the following:

- If the bay loading type is “Top”.
- If the BCU type is “Accuload-III or Accuload-IV”.

---

**Operations**

- **Truck Receipt Identification**: Click to select the check box.

**Receipt Source Selection**

- **Receipt by Compartment**: Select if you want to view receipts available for the identified vehicle and/or driver.

**Mode of Selection**

- **Enter Receipt Code**: The driver must enter the receipt code.
- **Confirmed Receipt**: The driver must confirm the receipt.
c. **Select From List**: The driver can select a receipt from a list of receipts available for the identified vehicle and/or driver within the configured date range.

31 Under **Receipt Input Status**, select the statuses of the receipt, based on which the driver can view the receipts. The default receipt input statuses are **CHECKED_IN** and **PARTIALLY_UNLOADED**.

32 Under **Bay Allocation**, select any one of the following:

- **Enforce**: The workflow validates whether the selected receipt is allocated to the current bay and is in the loading position in the queue. If this condition fails, then the receipt is not authorized in the particular bay and appropriate notifications are raised.

- **Check**: The workflow validates whether the selected receipt is recommended to the current bay. If this condition fails, then a notification is raised indicating that the receipt has come for unloading at a bay that is not the recommended bay. However, the receipt is authorized to unload in the particular bay.

- **None**: The workflow does not carry out any validations related to receipt bay allocation.

Note

Set the value of **Bay Allocation** option to **None** if bay allocation is not enabled for a site.

33 Under **Operations**, click **Truck Receipt Validation**. The **Truck Receipt Validations** check box is selected by default, and is unavailable for editing.
After you click **Truck Receipt Validation**, the following window appears.

34 Under **Receipt Validations**, perform the following:

a. Select the **Driver - Vehicle belongs to same carrier** check box, if the driver and the vehicle for a receipt must belong to the same carrier company.

b. Select the **Schedule date valid** check box, if you want to specify the duration for which the receipt can be viewed or selected by the driver at this bay.

   If you select the check box, the **Date range (+/-) days** box is available for editing. Type a value determining the range for which the receipt is valid. For example: If the value for the field **Date range (+/-) days** is set to 2 and if the scheduled date is January 10, the driver can view or select the receipts that are scheduled between January 8th (two days earlier than the scheduled date) and January 12th (two days later than the scheduled date).

35 Under **Operations**, click **Truck Receipt Close**. You can select this option when there is no exit gate in the terminal and the receipt must be closed, automatically by the workflow on successful unloading as per the receipt plan.
The following window appears.

![Window Displaying Loading Area Workflow](image.png)

36 Under **Report Options**, select the **Print BOD** check box, if you want to print a Bill of Discharge (BOD) report after a receipt is successfully unloaded at the bay.

37 Under **Bay Allocation Option**, select the **Bay Deallocation Required** check box, if you want to release the bay allocated for the current receipt.

38 Under **Operations**, click **Receipt Compartment Plan**.
The following window appears.

![Workflow Configuration Window](image)

39 Under **Loading Arm Options**, select one of the following:
   a. **Change Unloading Arm** option if you want to change the unloading arm.
   b. **Confirm Unloading Arm** option if you want to confirm the selected arm for unloading.

40 Under **Compartment Selection Options**, select one of the following:
   a. Select the **Confirm Compartment** check box, if the driver must confirm the compartment number.
   b. Select the **Enter Compartment Number** check box, if the driver must enter the compartment number from which the product must be unloaded.

41 Select the **Check Tank LineUp** check box, if you want to check the tanks lined up for the selected receipt.

42 Under **Operations**, select the **Local UnLoading** check box, if you want to upload the locally unloaded transaction details to the Terminal Manager database.

43 Click **Save**.
   The loading area workflow configuration is complete.
To configure bay workflow for Remote Interface Terminal (RIT) support

1. From the Standard Workflow Configuration Tool window, click the Loading Area tab.
   The loading area window appears.

2. From the Loading Area drop-down list, select the bays for which you want to configure various activities.
   The bays configured in the Site View Configuration page are listed.
   For example: Bay1_Gasoline
   The following window appears.

   The Driver Identification check box is selected by default for a bay. The BCU prompts for driver identification through access card, as per the site-wide configuration.
   After you click Driver Identification, the Driver Validations window appears.

4. Under Driver Validations, select the License 2 Expiry Required check box, if you want to validate the driver based on the expiry date of the driver’s second license.
   The mandatory validations such as whether the driver is valid, shareholder is active, and so on, are displayed on the lower half of the page.

   The Vehicle Identification check box is selected by default, and all the mandatory validations are performed. The BCU prompts for vehicle
identification through access card, as per the site-wide configuration. After you click **Vehicle Identification**, the vehicle validation window appears.

6 Under **Operations**, click **Shipment Identification**. The **Shipment Identification** check box is selected by default. The workflow prompts for shipment confirmation, as per the shipment validation configurations.

7 Under **Shipment Source Selection**, select the **Shipment By Compartment** check box if you want to view shipments available for the identified vehicle and/or driver, at the bay. The default value for shipment source is **Shipment By Compartment**.

8 If you have selected shipment by compartment as the source for shipment selection, then choose only **Confirmed Shipment** under **Mode of Selection**. The driver must confirm the shipment for the identified vehicle.

9 Under **Shipment Input Status**, select the statuses of the shipments, based on which the driver can view the shipments. The default shipment input statuses are **CHECKED_IN** and **PARTIALLY_LOADED**.

10 Under **Bay Allocation**, select any one of the following:

   - **Enforce**: The workflow validates whether the selected shipment is allocated to the current bay, and is in the loading position. If this condition fails, then the shipment is not authorized in the particular bay and appropriate notifications are raised.

   - **Check**: The workflow validates whether the selected shipment is recommended to the current bay. If this condition fails, then a notification is raised indicating that the shipment has come for loading at a bay that is not the recommended bay. However, the shipment is authorized to load in the particular bay.

   - **None**: The workflow does not carry out any validations related to shipment bay allocation.

**Note**

Set the value of **Bay Allocation** option to **None** if the shipment source selection is either from order or from contract, and if the shipment is being created for a vehicle in the bay for the first time.

11 Under **Operations**, click **Shipment Validations**. The **Shipment Validations** check box is selected by default and is unavailable for editing. The **Shipment Validations** window appears.
12 Under **Shipment Validations**, perform the following:
   a. Select the **Driver - Vehicle belongs to same carrier** check box, if the driver and the vehicle for a shipment must belong to the same carrier company.
   b. Select the **Schedule date valid** check box, if you want to specify the duration for which the shipment can be viewed or selected by the driver at this bay.
      If you select the check box, the **Date range (+/-) days** box is available for editing. Type a value determining the range for which the shipment is valid.
      For example: If the value for the field **Date range (+/-) days** is set to 2 and if the scheduled date is January 10, the driver can view or select the shipments that are scheduled between January 8th (two days earlier than the scheduled date) and January 12th (two days later than the scheduled date).

13 Under **Operations**, click **Compartment Plan**.
   The following window appears.

14 Under **Compartment Plan Options**, perform the following for RIT:
   - Clear the **Replan Preset Quantity** check box as the user cannot re-plan the preset quantity.
   - Clear the **Return Quantity** check box.

15 Under **Loading Arm Options**, click the **Confirm Loading Arm** option, if you want to confirm the selected arm for loading.
16 Clear the Enter Compartment Number option.

17 Under Operations, click Monitor Loading. The Monitor Load Options window appears.

18 Under Monitor Loading, the following check boxes are selected by default.

- **Flow Rate**: To monitor the flow rate of the product during loading.
- **Temperature**: To monitor the temperature of the product during loading.
- **Density**: To monitor the density of the product during loading.
- **Pressure**: To monitor the pressure of the product during loading.
- **Mass**: To monitor the mass of the product during loading.
- **Totalizer**: To monitor the totalizer of the product during loading.

If you do not want to monitor any or all of these details, you can clear any or all of these check boxes.

19 Under Operations, click Leakage. The Leakage Capture Options window appears.

20 Select the Before Loading check box, to capture the leakage details of the loading arm, before the loading of product begins.

21 Under Operations, select the Local Loading check box, if you want to upload the locally loaded transaction details to the Terminal Manager database.

**Note**

Ensure that you do not select the Truck Receipt Identification and Truck Receipt Validation check boxes and skip steps 22 to 32 for the following:

- If the bay loading type is “Top”.
- If the BCU type is “Accuload-III or Accuload-IV”.

22 Under Operations, click Truck Receipt Identification. The Truck Receipt Identification check box is selected by default. The workflow prompts for receipt selection and/or confirmation, as per the receipt validation configurations.
After you click **Truck Receipt Identification**, the following window appears.

23 Under **Receipt Source Selection**, select the **Receipt By Compartment** check box if you want to view receipts available for the identified vehicle and/or driver, at the bay.

24 Under **Mode of Selection**, click the **Confirmed Receipt** option. The driver must confirm the receipt for the identified vehicle and/or driver.

25 Under **Receipt Input Status**, select the statuses of the receipt, based on which the driver can view the receipts.

26 The default receipt input statuses are **CHECKED_IN** and **PARTIALLY_UNLOADED**.

27 Under **Bay Allocation**, select any one of the following:

- **Enforce**: The workflow validates whether the selected receipt is allocated to the current bay, and is in the loading position in the queue. If this condition fails, then the receipt is not authorized in the particular bay and appropriate notifications are raised.

- **Check**: The workflow validates whether the selected receipt is recommended to the current bay. If this condition fails, then a notification is raised indicating that the receipt has come for unloading at a bay that is
not the recommended bay. However, the receipt is authorized to unload in
the particular bay.

- **None**: The workflow does not carry out any validations related to receipt
  bay allocation.

---

**Note**

Set the value of **Bay Allocation** option to **None** if bay allocation is not enabled for a site.

---

28 Under **Operations**, click **Truck Receipt Validations**. The **Truck Receipt Validations** check box is selected by default, and is unavailable for editing. The **Receipt Validations** window appears.

29 Under **Receipt Validations**, perform the following:

- Select the **Driver - Vehicle belongs to same carrier** check box, if the
driver and the vehicle for a receipt must belong to the same carrier
  company.

- Select the **Schedule date valid** check box, if you want to specify the
duration for which the receipt can be viewed or selected by the driver at
  this bay.

  If you select the check box, the **Date range (+/-) days** box is available for
  editing. Type a value determining the range for which the receipt is valid.
  For example: If the value for the field **Date range (+/-) days** is set to 2
  and if the scheduled date is January 10, the driver can view or select the
  receipts that are scheduled between January 8th (two days earlier than the
  scheduled date) and January 12th (two days later than the scheduled date).
30 Under **Operations**, click **Receipt Compartment Plan**. The following window appears.

![Image of workflow configuration tool]

31 Under **Loading Arm Options**, ensure that you only click the **Confirm Unloading Arm** option.

32 Clear the **Enter Compartment Number** option.

33 Under **Operations**, select the **Local UnLoading** check box, if you want to upload the locally unloaded transaction details to the Terminal Manager database.

34 Click **Save**.
The loading area workflow configuration for RIT support is complete.
2.6 Configuring Exit Gate Workflow

An exit gate is a location where the vehicle exits the terminal after completion of loading. An exit gate may include operations pertaining to BOL office (if a BOL office location is not configured) and weighing area (if weighbridge is used for weighing both the tare weight and laden weight). The validations for driver, vehicle, shipment, and receipt are performed at an exit gate.

You can configure the workflow for the exit gate. The possible devices at this location are card reader, PCDET, and weighbridge.

To configure exit gate workflow

1. From the Standard Workflow Configuration Tool window, click the Exit Gate tab.
   The exit gate window appears.

2. From the Exit Gate drop-down list, select the exit gate for which you want to configure various activities.
   The exit gates configured in the Site View Configuration page are listed.
   For example: ExitGate1x.
   The following window appears.

   The Driver Identification check box is selected by default for an exit gate.
   The exit gate workflow or the PCDET prompts for driver identification.
through access card or PIN- password as per the site-wide configuration. After you click **Driver Identification**, the following window appears.

4 Under **Driver Validations**, select the **License 2 Expiry Required** check box, to validate the driver based on the expiry date of the driver’s second license. The mandatory validations such as whether the driver is valid, shareholder is active, and so on, are displayed on the lower half of the page.

5 Under **Operations**, click **Vehicle Identification**. The **Vehicle Identification** check box is selected by default. The exit gate workflow or the PCDET prompts for vehicle identification through access card or PIN, as per the site-wide configuration.
After you click **Vehicle Identification**, the following window appears.

![Vehicle Identification Window](image)

6. **Under Vehicle Validation**, perform the following:
   - Select the **Record Laden Weight** check box if you want to weigh the laden weight of the vehicle at the exit gate.
   - Select the **Record Truck Receipt Tare Weight** check box if you want to weigh the tare weight of the vehicle at the exit gate for truck receipts.

7. **Under Operations**, click **Shipment Identification**. The **Shipment Identification** check box is selected by default. The exit gate workflow or the PCDET prompts for shipment selection, as per the shipment validation configurations.
After you click **Shipment Identification**, the following window appears.

8. Under **Mode of Selection**, select any of the following:
   - **Enter Shipment Code**: The driver must enter the shipment code to select the shipment.
   - **Driver**: To view the shipments based on the driver identification.
   - **Vehicle**: To view the shipments based on the vehicle identification. The default value for shipment selection is **Vehicle**.

9. Under **Shipment Input Status**, select the statuses of the shipments, based on which the driver can view the shipments. For example: If the input status is selected as **AUTO_LOADED** and **MANUALLY_LOADED**, the driver can view or select only the shipments that are in **AUTO_LOADED** or **MANUALLY_LOADED** states. The default shipment input statuses are **AUTO_LOADED** and **MANUALLY_LOADED**.

10. Under **Shipment Output Status**, select the status to which the shipment must be updated by the exit gate workflow, after all exit gate operations are performed. For example: If the output status is selected as **CLOSED**, the status of the selected shipment is updated to **CLOSED**, after all exit gate operations are performed. The default shipment output status is **CLOSED**.
11 Under **Bay Allocation Option**, select the **Bay DeAllocation Required** check box if you want to release the bay allocated for the current shipment.

12 Under **Operations**, click **Truck Receipt Identification**. The **Truck Receipt Identification** check box is selected by default. The exit gate workflow or the PCDET prompts for receipt selection, as per the receipt validation configurations. After you click **Truck Receipt Identification**, the following window appears.

13 Under **Mode of Selection**, select any of the following:

- **Enter Receipt Code**: The driver must enter the receipt code to select the receipt.
- **Driver**: To view the receipts based on the driver identification.
- **Vehicle**: To view the receipts based on the vehicle identification.
  
  The default value for receipt selection is **Vehicle**.

14 Under **Receipt Input Status**, select the statuses of the receipts, based on which the driver can view the receipts. For example: If the input status is selected as **AUTO_UNLOADED** and **MANUALLY_UNLOADED**, the driver can view or select only the receipts that are in **AUTO_UNLOADED** or **MANUALLY_UNLOADED** statuses. The default receipt input statuses are **AUTO_UNLOADED** and **MANUALLY_UNLOADED**.

15 Under **Receipt Output Status**, select the status to which the receipt must be updated by the exit gate workflow, after all exit gate operations are performed. For example: If the output status is selected as **CLOSED**, the status of the
selected receipt is updated to **CLOSED**, after all exit gate operations are performed.
The default receipt output status is **CLOSED**.

16 Select the **Print BOD** check box if you want to print the bill of discharge report.

17 Under **Bay Allocation Option**, select the **Bay Deallocation Required** check box if you want to release the bays allocated for the current receipt at the exit gate. If this check box is selected, bays are automatically released from the selected receipt at the exit.

18 Click **Save**.
The exit gate workflow configuration is complete.
2.7 Configuring Notification Messages for DIDO and Swing Arm Input

You can configure the failure notification messages for Digital Input and Digital Output (DIDO) for each BCU configured in site view.

- You can also configure general programmable input number (PIN) for swing arms. This indicates the PIN in the BCU to which the swing arm is connected.
  For example:

- For Contrec 1010CJ and Contrec 1010 CB, if the swing arm position input is connected to the BCU input board connectors “CA25[In+]/CA24[In-]”, then you must type 5 in the Arm Position GP Input column.

- For Dual Bay MSCL, if the position value of Bay 1 is DI_DC_1 and the position value of Bay 2 is DI_DC_2, then you must type DI_DC_1, DI_DC_2 in the Arm Position GP Input column.

<table>
<thead>
<tr>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>- DIDO messages are applicable only for Accuload-III, Accuload-IV, Contrec 1010CB, Contrec 1010CJ, and MSC-L BCUs.</td>
</tr>
<tr>
<td>- Swing arm feature is applicable for Contrec 1010CB, 1010CJ BCUs and Dual Bay MSCL only.</td>
</tr>
</tbody>
</table>

To configure DIDO for BCUs

1. From the Standard Workflow Configuration Tool window, click the BCU Configuration tab.

2. From the Batch Controller drop-down list, select the BCU for which you want to configure the workflow. The BCUs which are associated in the Site View configuration page are listed.

3. If you are configuring DIDOs for Accuload-III, Accuload-IV, Contrec 1010CB, or Contrec 1010CJ BCUs.
The following window appears.

The DIDO configurations for the BCU are listed in the **DIDOType** list.

a. In the **Message Code** list, type the message for the notification to be raised for the corresponding condition.

The following window appears.
The **Swing Arm Code** list displays the swing arms configured for the selected BCUs.

b. In the Arm Position GP Input box, type the value of the swing arm position as follows:

- For Contrec 1010CJ and Contrec 1010 CB, type the general purpose input PIN number (in the BCU) of the swing arm.
  For example, if the swing arm position input is connected to the BCU input board connectors “CA25[In+)/CA24[In-]”, then the value of the swing arm position is 5.

- For Dual Bay MSCL, type the swing arm position values of Bay 1 and Bay 2 (as configured in the MSCL) separated by a comma.
  For example, if the position value of Bay 1 is **DI_DC_1** and the position value of Bay 2 is **DI_DC_2**, then the value of the swing arm position is **DI_DC_1, DI_DC_2**.

---

**Note:**
The tool always considers the first half of the comma-separated string as the position value for Bay 1, and the second half for Bay 2.
4 If you are configuring DIDOs for MSC-L BCUs. If the BCU selected is MSC-L single bay, the window appears as follows.

a. For MSC-L BCUs, perform the following under **General Configuration**:

- In the **Emergency Shutdown** drop-down list, select the DI input configured for emergency shutdown in the MSC-L BCU. The options available are DI_DC_1 to DI_DC_60 and DI_AC_1 to DI_AC_12.

- Select the **Allow simultaneous loading** check box if you want to enable simultaneous loading on the MSC-L device. During the local loading, the **Load Another Compartment Prompt** is displayed based on this setting on the MSC-L device.

b. For MSC-L BCUs, perform the following under **Permissives Configuration**:

- In the **Grounding** drop-down list, select the DI input configured for grounding in the MSC-L BCU. The options available are DI_DC_1 to DI_DC_60 and DI_AC_1 to DI_AC_12.

- In the **OverFill** drop-down list, select the DI input configured for overfill in the MSC-L BCU. The options available are DI_DC_1 to DI_DC_60 and DI_AC_1 to DI_AC_12.

- In the **Vapour Recovery** drop-down list, select the DI input configured for vapor recovery in the MSC-L BCU.
The options available are DI_DC_1 to DI_DC_60 and DI_AC_1 to DI_AC_12.
Ensure that you select different values for each of the permissive configurations.
If the BCU selected is MSC-L dual bay, the window appears as follows.

c. For MSC-L BCUs, perform the following under General Configuration:
   • In the Emergency Shutdown drop-down list, select the DI input configured for emergency shutdown in the MSC-L BCU.
     The options available are DI_DC_1 to DI_DC_60 and DI_AC_1 to DI_AC_12.
     Select the Allow simultaneous loading check box if you want to enable simultaneous loading on the MSC-L device. During the local loading, the Load Another Compartment Prompt is displayed based on this setting on the MSC-L device.

d. For MSC-L BCUs, perform the following under Permissives Configuration for each of the bay:
   • In the Grounding drop-down list, select the DI input configured for grounding in the MSC-L BCU.
     The options available are DI_DC_1 to DI_DC_60 and DI_AC_1 to DI_AC_12.
     • In the OverFill drop-down list, select the DI input configured for overfill in the MSC-L BCU.
The options available are DI_DC_1 to DI_DC_60 and DI_AC_1 to DI_AC_12.

- In the Vapour Recovery drop-down list, select the DI input configured for vapor recovery in the MSC-L BCU. The options available are DI_DC_1 to DI_DC_60 and DI_AC_1 to DI_AC_12.

- In the Bay Number box, type the same bay number that is configured for the MSCL. Ensure that you select different values for each of the permissive configurations.

e. For MSC-L BCUs, perform the following under Bay Configuration:

- In the Bay 1 Name drop-down list, select the BCU associated with the Bay 1 in the MSC-L dual bay BCU device.

- In the Bay 2 Name drop-down list, select the BCU associated with the Bay 2 in the MSC-L dual bay BCU device.
5 If you are configuring DIDOs for Multiload-II BCUs, the window appears as follows

![DIDO Configuration Window]

a. For Multiload-II BCUs, configure notification messages for Digital Input and Digital Output (DIDO) by selecting FCM and Port number as per device setup

b. For Multiload-II BCUs, perform the following under **Permissives Configuration**:

- In the **Grounding** drop-down list, select the FCM and the respective port configured for grounding in the Multiload-II BCU.
- In the **Emergency Shutdown** drop-down list, select the FCM and the respective port configured for emergency shutdown in the Multiload-II BCU.
- Under Unit Configuration select configured average pressure and average temperature for the device.

6 Click **Save**.

The DIDO configuration is complete for the selected BCU.

7 Repeat the above steps to configure DIDO for other BCUs as applicable.
2.8 Configuring Recipes

A recipe is a pure base product or a blend of two or more base products or a base product and one or more additives. You can configure the recipe numbers for each finished product.

**Note**

Recipe configuration is applicable only for Accuload-III, Accuload-IV, Contrec 1010CB, Multiload-II, and MSC-L BCUs. In case of Multiload-II, Component and Additive Index should be specified as per the device configuration.

**To configure recipe**

1. From the **Standard Workflow Configuration Tool** window, click the **Recipe Configuration** tab.

2. From the **Batch Controller** drop-down list, select the BCU for which you want to configure the recipe.
   
   The BCUs configured in the **Device Configuration** page are listed. Ensure that you have configured a loading arm for a BCU in the **Site View** configuration page.
   
   For example: AcculoadIII_Bay01_2
   
   The following window appears.

   ![Recipe Configuration Window](image)

   The loading arm for the selected BCU is displayed in the **Loading Arm** drop-down list.
The finished products that can be loaded using the BCU are displayed in the **Finished Product Code** list.

3 Click the finished product in the **Finished Product Code** column. The following window appears.

4 In the **Recipe Number** column, type the recipe number for the selected finished product. Ensure that the recipe number configured in the BCU for the finished product matches the value entered in this field. For example: If the finished product is Diesel and if the recipe number configured in the BCU is 1, then type the recipe number as “1” in this field.

5 In the **BP Code** column, the base products from which the finished product is obtained are listed. Type the sequence in which the product must be loaded in the **DP Number** column. In case of MSC-L, the DP number indicates the sequence in which product streams are configured for that recipe on device.

6 In the **Meter Code** column, the meter used for measuring the base product loaded is listed. Type the meter number for the meter in the **Meter Number** list. In case of MSC-L, ensure that the value for meter number is same as the value configured in “BCU Meter Reference Number” field in Site View.

7 In the **AD Code** column, the additives available in the finished product are listed. Type the additive injector position or the additive number in the **Additive Number** list. The meter code for the additive meter and the base product associated to the
87

8. Repeat the above steps to configure recipe for other listed finished products.

9. Click Save.
The recipe configuration is complete for the selected BCU.

10. Repeat the above steps to configure recipe for other BCUs as applicable.
The following figure displays a sample recipe configuration for the Accuload-III BCU.
2.9 Downloading Density

You can download the density values to the batch controller unit. Density downloaded can be of two types namely the manual density updated in tank or the live density from ATG when the ATG Exe is running.

**Configurations in Standard Workflow Configuration Tool**

- In the Standard Workflow Configuration Tool, select the **Allow Density** check box under **Compartment Plan Operations** in the **Loading Area** tab if you want to download the density value to the BCU. If the BCU has multiple arms, each arm has the download SCADA density parameter. For example: For arm 1 of BCU, the download SCADA density parameter is **BCU_Arm01.downloaddensity**.

**Configurations on Terminal Manager**

- Set the value for the lookup **Contrec1010CJCommodityType** under the lookup type **WorkflowConfiguration** as **ALLPROD-0,BLACK-0,LPG-5, WHITE-1**. This is used to map the product type of the base product of the meter to the corresponding commodity type set in the BCU metering line configuration for MSC-L, Contrec 1010CJ, and Contrec 1010CB.

- While configuring a BCU, ensure that you select the density unit of measurement in the **Density UOM** drop-down list.

**Configurations on BCU**

- On the batch controller, choose **METERLINES > CORRECTION > COMMODITYTYPE**.

- Set the value of the commodity type as **A-CrudeOil** or any other commodity type. Ensure that you configure the Density Range within the range specified in the following table.
DOWNLOADING DENSITY

- Run the workflow.
- Set the SCADA point parameter Download Density for a particular arm to 1.
- Load a shipment using the workflow.

After the loading is complete, density values are updated to loading details.

**Note**

The density is downloaded only when the Earth input to the BCU is not connected with the vehicle’s Earth.

### Commodity Types

<table>
<thead>
<tr>
<th>Commodity Types</th>
<th>0 – None</th>
<th>1 – Crude oils (A)</th>
<th>2 – Refined (B)</th>
<th>3 – Special (C)</th>
<th>4 – Lube oils (D)</th>
<th>5 - NGL and LPG (E)</th>
</tr>
</thead>
</table>

### Relative Density (RD 60)

<table>
<thead>
<tr>
<th>Units</th>
<th>Base temp</th>
<th>Crude Oils(A)</th>
<th>Refined(B)</th>
<th>Special(C-thermal exp.)</th>
<th>Lube Oils (D)</th>
<th>NGL and LPG(E)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Kg/m3</td>
<td>60 °F</td>
<td>0.61120 to 1.16464</td>
<td>NA</td>
<td>0.80168 to 1.1646</td>
<td>0.3500 to 0.6880</td>
<td></td>
</tr>
<tr>
<td></td>
<td>15 °C</td>
<td>NA</td>
<td>NA</td>
<td>800.9 to 1163.5</td>
<td>351.7 to 687.8</td>
<td></td>
</tr>
<tr>
<td></td>
<td>20 °C</td>
<td>NA</td>
<td>NA</td>
<td>800.9 to 1163.5</td>
<td>331.7 to 683.6</td>
<td></td>
</tr>
</tbody>
</table>
2.10 Configurations for card download

You can download the access card information from Terminal Manager to a batch controller unit.

To enable download of card information, you must perform the following configurations.

To download NexWatch card information of driver

To download the NexWatch card information for a driver, perform the following:

1. From the Standard Workflow Configuration Tool window, click the Site Configuration tab.
2. Under Operations on the left pane, click Driver under Entities. The Driver window appears.
4. Click Save.
5. Click the Loading Area tab.
6. Under Operations on the left pane, select the Driver Identification check box.
7. Click Save.
   The settings for access card of driver are saved.

To download NexWatch card information of vehicle

To download the NexWatch card information for a vehicle, perform the following:

1. From the Standard Workflow Configuration Tool window, click the Site Configuration tab.
2. Under Operations on the left pane, click Vehicle under Entities. The Vehicle window appears.
4. Click Save.
5. Click the Loading Area tab.
6. Under Operations on the left pane, select the Vehicle Identification check box.
7. Click Save.
   The settings for access card of vehicle are saved.
To download Nedap RFID information of vehicle

To download the Nedap RFID information for a vehicle, perform the following:

1. From the **Standard Workflow Configuration** Tool window, click the **Site Configuration** tab.
2. Under **Operations** on the left pane, click **Vehicle** under **Entities**. The **Vehicle** window appears.
3. Under **Identification Source**, click **RFID**.
4. Click **Save**.
5. Click the **Loading Area** tab.
6. Under **Operations** on the left pane, select the **Vehicle Identification** check box.
7. Click **Save**.
   The settings for access card of vehicle are saved.
**Note**

**For Contrec 1010CB and 1010CJ BCUs**

- The current release of Terminal Manager does not support download of card information when the driver identification is through PIN and the vehicle identification is through access card or RFID.

- If you want to download access card information and if a driver is identified using access card, then ensure that you set the value of **Personnel Authorisation** to **NexWatch** on the BCU.

- If you want to download access card information and if a vehicle is identified using access card, then ensure that you set the value of **Vehicle Authorisation** to **NexWatch** on the BCU.

- If you want to download access card information and if a vehicle is identified using RFID, then ensure that you set the value of **Vehicle Authorisation** to **NEDAP RFID** on the BCU.

**For MSC-L BCUs**

- Driver PIN(Virtual) and Access Card(Electronic) is downloaded to User Database of MSCL.

- Vehicle PIN(Virtual), Access Card and RFID(Electronic) is downloaded to Object Database of MSCL.

- For AccessCard and RFID download, integrated card reader should be enabled on Terminal Manager. If it is non-integrated, then lookup for access card download should be set to False.

- If you want to download driver card information, ensure that the value of Main menu > System Configuration > Device > Communication > Serial > COM – N > Authorization > Database selection is set to “User”.

- If you want to download vehicle card information, ensure that the value of Main menu > System Configuration > Device > Communication > Serial > COM – N > Authorization > Database selection is set to “Object” and “Attribute” is set to “Vehicle”.

---

Honeywell
**Configurations on Terminal Manager**

Configure the values for the lookup **AccessCardDownloadToBCU**, as applicable.

<table>
<thead>
<tr>
<th>Lookup Type Name</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AccessCardDownloadRequired</td>
<td>FALSE</td>
<td>If the value of this field is set to <em>TRUE</em>, the access card information is downloaded to the BCU. If the value of this field is set to <em>FALSE</em>, the access card information is not downloaded to the BCU.</td>
</tr>
<tr>
<td>AccessCardDownloadInterval</td>
<td>30</td>
<td>The interval in minutes required for downloading the access card information to BCU.</td>
</tr>
</tbody>
</table>
2.11 Export Configuration

You can export the configurations of device, location, finished product, and workflow. These configurations can be imported later to the site. The options to export and import configurations reduce the configuration time required at the site.

To export configuration

1. From the **Standard Workflow Configuration** Tool window, choose **File > Export Configuration**.
   The **Save As** dialog box appears.

2. Browse to the location where you want to save the exported configuration as an SQL script file.

3. Click **Save**.
   The configurations of device, location, finished product, tank, and workflow are successfully exported.

**Note**

The Standard Workflow Configuration Tool does not allow you to export the point parameter SCADA mappings for the BCU and virtual preset configurations. Therefore, you must recreate the mapping after importing the device configuration into a new system.
2.12 Import Configuration

You can import the configurations of device, location, finished product, and workflow that are already exported.

Note

The Standard Workflow Configuration Tool does not allow you to import the point parameter SCADA mappings for the BCU and virtual preset configurations. Therefore, you must recreate the mapping after importing the device configuration into a new system.

To import configuration

1. From the Standard Workflow Configuration Tool window, choose File > Import Configuration.
   The Open dialog box appears.
2. Browse to the location where the exported SQL script file is located.
3. Select the SQL script file and then click Open.
   All configurations are imported successfully.
2.13 Generating Process Configuration automatically

You can create Workflow application for BCUs and card readers using the Standard Workflow Configuration Tool. You can generate Workflow application and device driver workflow for all BCUs and card readers respectively in a terminal. The Workflow applications are generated for all the devices at the same time. The Workflow applications are also displayed in the Process Configuration page in Terminal Manager.

Attention

- Ensure that you stop the process monitor service before generating process configurations.
- Ensure that you always run the tool on the active Experion server.
- Ensure that you manually place the generated Workflow applications in the backup server.
- Ensure that you have already completed all the master and site view configurations in Terminal Manager.

The following sections describe how to generate Workflow applications using the Standard Workflow Configuration Tool.

To automatically generate EXEs

1. From the Standard Workflow Configuration Tool window, choose File > Generate Process Configuration.

The Generate Process Configuration window appears.
2 Perform one of the following:
   • To generate workflow application for BCUs and/or virtual presets, click **Generate BCU Workflow**.
   • To generate device driver workflows for card readers, click **Generate Card Reader Workflow**.

The workflow application or device driver workflows generated for BCU/virtual preset or card reader respectively are displayed in the **Process Configuration created** box as shown in the following figure.
2. 13.1. Scenarios for EXE Generation

The following table represents the various scenarios considered for generating EXEs.

<table>
<thead>
<tr>
<th>Device Type</th>
<th>Exe Type</th>
<th>Multi-drop</th>
<th>Location Specific</th>
<th>Exe Generation</th>
<th>Exe Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>BCU</td>
<td>WorkflowApplication</td>
<td>No</td>
<td>NA</td>
<td>An EXE named “WorkflowApplication_ BCUName” is generated for each BCU across locations.</td>
<td>InstallPath/ TerminalManager/ Workflow/ BCU</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Yes</td>
<td>NA</td>
<td>A BCU is randomly selected from the list of multi-dropped BCUs which share the same channel across locations, and an exe is generated as “WorkflowApplication_ BCUName”. For MSC-L BCU model, the EXE is generated as “MSCWorkflow_ BCUName.exe”.</td>
<td>InstallPath/ TerminalManager/ Workflow/ BCU</td>
</tr>
<tr>
<td></td>
<td>VirtualPresetWorkflowApplication</td>
<td>NA</td>
<td>Yes</td>
<td>An EXE named &quot;VirtualPresetWorkflow_ BCUName&quot; is generated under a given location type. One EXE is generated for every three BCUs of model Virtual Preset. For example: If four BCUs of model Virtual Preset are present in a location of type “Marine Bay”, then 1 EXE is generated for the first 3 BCU(S) and 1 more EXE is generated for the fourth BCU.</td>
<td>InstallPath/ TerminalManager/ Workflow/ VirtualPreset</td>
</tr>
<tr>
<td>Card Reader</td>
<td>AccessIDReaderApplication</td>
<td>No</td>
<td>NA</td>
<td>An EXE named “AccessIDReaderApplication_ CRName” is generated for each card reader across locations.</td>
<td>InstallPath/ TerminalManager/ Workflow/ CardReader</td>
</tr>
</tbody>
</table>
### Generating Process Configuration Automatically

<table>
<thead>
<tr>
<th>Card Reader</th>
<th>AccessIDReaderApplication</th>
<th>Yes</th>
<th>NA</th>
<th>A card reader is chosen randomly from the list of multi-dropped card readers which share the same channel across locations, and an EXE is generated as “AccessIDReaderApplication_CRName”.</th>
<th>InstallPath/ TerminalManager/ Workflow/ CardReader</th>
</tr>
</thead>
<tbody>
<tr>
<td>EntryExitApplication</td>
<td>No</td>
<td>Exit Gate</td>
<td>If a PCDET is not associated to an exit gate, EXE (s) for all card reader(s) present in the location as “EntryExitApplication_CRName” are generated.</td>
<td>InstallPath/ TerminalManager/ Workflow/ EntryExit</td>
<td></td>
</tr>
<tr>
<td>EntryExitApplication</td>
<td>No</td>
<td>Entry Gate</td>
<td>If a PCDET is not associated to an entry gate, EXE(s) for all card reader(s) present in the location are generated as “EntryExitApplication_CRName”.</td>
<td>InstallPath/ TerminalManager/ Workflow/ EntryExit</td>
<td></td>
</tr>
</tbody>
</table>

**Attention**

If you want to generate workflow application and device driver workflow for a device, you must associate the device to appropriate location. If the devices are multi-dropped, then you must associate the multi-dropped devices to the appropriate locations. However, if any one of the multi-dropped devices is not associated to a location, you must manually configure workflow application and device driver workflow.
2.13.2. How the EXEs are generated

1. By default, the “Workflow” folder is available in the Terminal Manager installation path …\Honeywell\TerminalManager\Workflow.

2. The “BCU”, “CardReader”, and “EntryExit” folders are deployed during installation. These folders consist of reference EXEs, based on which new EXEs are generated for each workflow type.

3. When you generate a new EXE from the tool, a “Backup” folder is created within the “Workflow” folder. This backup folder in turn consists of “BCU”, “VirtualPreset”, “CardReader”, and “EntryExit” folders. The existing EXEs of devices are backed up and stored in the respective folders.

4. When you generate an EXE for the first time, the existing reference EXE is moved to a folder named “ReferenceWorkflow” in the path C:\Program Files(x86)\Honeywell\TerminalManager \Workflow\Backup\<Device>. For example: If you generate a card reader EXE, then the existing reference card reader EXE is moved to C:\Program Files (x86)\Honeywell\TerminalManager\Workflow\Backup\CardReader\ ReferenceWorkflow.

5. When you generate an EXE for the first time, the new EXE is created in the path C:\Program Files (x86)\Honeywell\TerminalManager\Workflow\<Device>. For example: If you generate a new card reader EXE, the new card reader EXE is created in the path C:\Program Files (x86)\Honeywell\TerminalManager\Workflow\CardReader.

6. Every time you generate a new EXE, the existing EXE is moved into a new folder within the “Backup” folder. The format for the name of the new folder is <Device>_Date_Time. For example: If you regenerate an EXE for card reader, the existing EXE is moved to a folder named “CardReader_2013.04.26_11.08.09” in the path C:\ Program Files(x86)\Honeywell\TerminalManager\Workflow\Backup\ CardReader.

7. The same steps are repeated for other workflow type EXEs.
2.14 Generating Point Files

You can generate point files for site view, bay allocation, bay, BCU, DEU, card reader, weighbridge, and ATG.

Note

Ensure that you generate point files whenever there is a change in device or site view configurations.

2.14.1. Generating Site View Point File

Using the Standard Workflow Configuration Tool, you can generate a point file that contains SCADA points. This SCADA point contains the summary of the truck site view configurations. The name of the generated SCADA point is “TMSiteView”.

To generate site view point file

1. From the Standard Workflow Configuration Tool window, choose File > Generate Point File.
   The Generate Point File window appears.

2. Select the Generate Site View Point File check box and then click Generate. The Workflow Configuration Tool box appears.

3. Click Yes to download the SCADA points to Experion. The Save As dialog box appears asking you to save the point file. If you have chosen to download the point file, then the SCADA points in the file are downloaded to Experion.
If you click No, the SCADA point file is saved in the specified location. You must then manually export the SCADA point file to Experion machine.

4 In the File name box, TMSiteView.pnt is displayed by default. If you want to change the name, enter a new name for the point file.

5 Click Save.
   A dialog box appears indicating that a point file for site view is generated.

6 Click OK to close the dialog box.

2.14.2 Generating Bay Allocation Point File

Using the Standard Workflow Configuration Tool, you can generate a point file that contains SCADA points. These SCADA points are used for configuring bay allocation, for all the allocated bays in the terminal under consideration.

You must export the generated point file to create the SCADA points in the Experion machine.

*Note*

The BAYPOINT1 is same as the point name configured for bay allocation in Terminal Manager.

**To generate bay allocation point file**

1 From the Standard Workflow Configuration Tool window, choose File > Generate Point File.
The **Generate Point File** window appears.

![Generate Point File window](image)

2. Select the **Generate Bay Allocation Point File** check box and then click **Generate**.
   
The Workflow Configuration Tool box appears.

3. Click **Yes** to download the SCADA points to Experion.
   
The **Save As** dialog box appears asking you to save the point file. If you have chosen to download the point file, then the SCADA points in the file are downloaded to Experion.

4. In the **File name** box, **BAY_ALLOCATION_POINT1.pnt** is displayed by default. If you want to change the name, enter a new name for the point file.

5. Click **Save**.
   
   A dialog box appears indicating that a point file for bay allocation is generated.

6. Click **OK** to close the dialog box.

### 2. 14.3. Generating Bay Point File

Using the Standard Workflow Configuration Tool, you can generate a point file that contains SCADA points. These SCADA points are used for configuring multiple BCUs per bay, for all the bays in the terminal under consideration.

You must export the generated point file to create the SCADA points in the Experion machine.
To generate bay point file

1. From the Standard Workflow Configuration Tool window, choose File > Generate Point File.
   The Generate Point File window appears.

2. Select the Generate Bay Point File check box and then click Generate. The Workflow Configuration Tool box appears.

3. Click Yes to download the SCADA points to Experion. The Save As dialog box appears asking you to save the point file. If you have chosen to download the point file, then the SCADA points in the file are downloaded to Experion.

Note
The BayPointName is same as the point name configured for the bay in Terminal Manager.
4 In the **File name** box, **QBDatabase_Bay.pnt** is displayed by default. If you want to change the name, enter a new name for the point file.

5 Click **Save**.
   A dialog box appears indicating that a point file for the bay is generated.

6 Click **OK** to close the dialog box.

2. 14.4. Generating BCU Point File

Using the Standard Workflow Configuration Tool, you can generate a point file that contains SCADA points for all the BCUs configured in Terminal Manager.

You must import the generated point file in to the Experion machine to create the SCADA points. The workflow uses this SCADA point to update loading details, channel status, and so on.

---

**Note**

The **BCUPointName** is same as the point name configured for the BCU device in Terminal Manager.
To generate BCU point file

1 From the Standard Workflow Configuration Tool window, choose File > Generate Point File.
   The Generate Point File window appears.

2 Select the Generate BCU Point File check box.
   After you select this check box, the Bay, MarineBay, and Cluster options are available for selection.
   The MarineBay and Cluster options are not available in Terminal Manager Box.

3 Select one of the following options:
   • Bay: To generate BCU point files for all bays.
   • MarineBay: To generate BCU point files for all berths.
     This option is not available in Terminal Manager Box.
   • Cluster: To generate BCU point files for all clusters.
     This option is not available in Terminal Manager Box.

4 Click Generate.
   The Workflow Configuration Tool box appears.

5 Click Yes to download the SCADA points to Experion.
   The Save As dialog box appears asking you to save the point file. If you have chosen to download the point file, then the SCADA points in the file are downloaded to Experion.
6 In the **File name** box, the default name for the point file is displayed. If you want to change the name, enter a new name for the point file.

- If you have selected the **Bay** option, the point file name is displayed as “QBDatabase_BCU_Bay”.
- If you have selected the **MarineBay** option, the point file name is displayed as “QBDatabase_BCU_MarineBay”.
- If you have selected the **Cluster** option, the point file name is displayed as “QBDatabase_BCU_Cluster”.

The **MarineBay** and **Cluster** options are not available in Terminal Manager Box.

7 Click **Save**.
A dialog box appears indicating that a point file for the BCU is generated.

8 Click **OK** to close the dialog box.

---

**Note**

If you want to generate device specific point file, you can use the **SCADA Configuration** tab.

---

### 2. 14.5. Generating DEU Point File

Using the Standard Workflow Configuration Tool, you can generate a point file that contains SCADA points for all the DEUs configured in Terminal Manager.

You must import the generated point file in to the Experion machine to create the SCADA points. The workflow uses this SCADA point to update current task, channel status, and so on.

---

**Note**

The DEUPointName is same as the as the point name configured for the DEU device in Terminal Manager.

---

**To generate DEU point file**

1 From the **Standard Workflow Configuration Tool** window, choose **File > Generate Point File**.
The **Generate Point File** window appears.

2 Select the **Generate DEU Point File** check box and then click **Generate**.
The **Workflow Configuration Tool** box appears.

3 Click **Yes** to download the SCADA points to Experion.
The **Save As** dialog box appears asking you to save the point file. If you have chosen to download the point file, then the SCADA points in the file are downloaded to Experion.
4 In the **File name** box, `QBDatabase_DEU.pnt` and `QBDatabase_1030DET.pnt` are displayed by default for touch screen and Contrec1030 DET respectively. If you want to change the name, enter a new name for the point file.

5 Click **Save**.
A dialog box appears indicating that a point file for the DEU is generated.

6 Click **OK** to close the dialog box.


Using the Standard Workflow Configuration Tool, you can generate a point file that contains SCADA points for all the card readers configured in Terminal Manager.

You must import the generated point file in to the Experion machine to create the SCADA points. The workflow uses this SCADA point to update card serial number detected, the time when the card is detected, channel status, and so on.

**Note**
The **CRPointName** is same as the as the point name configured for the card reader device in Terminal Manager.

**To generate Card Reader point file**

1 From the **Standard Workflow Configuration Tool** window, choose **File > Generate Point File**.
The **Generate Point File** window appears.

2 Select the **Generate Card Reader Point File** check box and then click **Generate**.
The **Workflow Configuration Tool** box appears.

3 Click **Yes** to download the SCADA points to Experion.
The **Save As** dialog box appears asking you to save the point file. If you have chosen to download the point file, then the SCADA points in the file are downloaded to Experion.

4 In the **File name** box, `QBDatabase_CardReader.pnt` is displayed by default. If you want to change the name, enter a new name for the point file.

5 Click **Save**.
A dialog box appears indicating that a point file for the card reader is generated.

6 Click **OK** to close the dialog box.
2. 14.7. Generating Weighbridge Point File

Using the Standard Workflow Configuration Tool, you can generate a point file that contains SCADA points for all the weighbridge configured in Terminal Manager.

You must import the generated point file into the Experion machine to create the SCADA points. The workflow uses this SCADA point to update measured weight and time, channel status, and so on.

To generate WeighBridge point file

1. From the Standard Workflow Configuration Tool window, choose File > Generate Point File.
   The Generate Point File window appears.

2. Select the Generate Weigh Bridge Point File check box and then click Generate.
   The Workflow Configuration Tool box appears.

3. Click Yes to download the SCADA points to Experion.
   The Save As dialog box appears asking you to save the point file. If you have chosen to download the point file, then the SCADA points in the file are downloaded to Experion.

4. In the File name box, QBDatabase_WeighBridge.pnt is displayed by default. If you want to change the name, enter a new name for the point file.

5. Click Save.
   A dialog box appears indicating that a point file for the weighbridge is generated.

6. Click OK to close the dialog box.
2. 14.8. Generating ATG Point File

Using the Standard Workflow Configuration Tool, you can generate a point file that contains SCADA points for all the ATGs configured in Terminal Manager.

To generate Server point file

1. From the Standard Workflow Configuration Tool window, choose File > Generate Point File. The Generate Point File window appears.

2. Select the Generate Server Point File check box and then click Generate. The following dialog box appears.

3. Click Yes to download the SCADA points to Experion. The Save As dialog box appears asking you to save the point file. If you have chosen to download the point file, then the SCADA points in the file are downloaded to Experion.

4. In the File name box, QBDatabase_Server.pnt is displayed by default. If you want to change the name, enter a new name for the point file.

5. Click Save. A dialog box appears indicating that a point file for the Servers is generated.

6. Click OK to close the dialog box.
2.15 Configuring Truck SCADA Attributes

You can configure the SCADA parameter names based on the transportation type. The configured values are common for all BCUs and/or virtual preset controllers existing for the particular transportation type.

You can define the SCADA parameter names for all the attributes based on the transportation type. You can define whether the attribute value is taken from SCADA or process point parameter, define the data type of the SCADA attribute, and also make any attributes inactive if not being used.

The following section describes the steps to configure truck SCADA attributes. The procedure to configure pipeline, marine, and rail SCADA attributes are similar.

REFERENCE - EXTERNAL

For more information about various SCADA attributes for different transportation types, refer to Terminal Manager 681.1 Application Customization Guide.

To configure SCADA attributes

1. From the Standard Workflow Configuration Tool window, choose File > ROAD.

2. Click the SCADAAttributeConfiguration tab.
   The window appears as follows.

3. In the Type drop-down list, click BCU.
4 In the Attribute Type drop-down list, click Device. The window appears as follows.

![Attribute Configuration Window](image)

All the attributes for the device are listed along with the details such as attribute code, attribute description, parameter name, and so on. The values for fields such as IsMandatory, DataType, IsActive, and so on are displayed by default.

5 To update the details for any attribute, select the attribute from the Attribute Code list, and then perform the following:
   a. Select the IsProcessPoint check box if the values must be updated by the process point. If this check box is cleared, the values are updated by SCADA.
   b. In the Parameter Name list, type the new parameter name for the attribute.
   c. Select the IsReadOnly check box if Terminal Manager must only read attribute values from the corresponding SCADA parameter or process point parameter.
6 In the **Attribute Type** drop-down list, click **TransactionPlan**. The window appears as follows.

![Image of Attribute Type drop-down list]

All the attributes for the transaction plan are listed along with the details such as attribute code, parameter name, and so on.

7 To update the details for any attribute, select the attribute from the Attribute Code list, and then perform the following:

   a. Select the **IsProcessPoint** check box if the values must be updated by the process parameter. If this check box is cleared, the values are updated by SCADA.

   b. In the **Parameter Name** list, type the new parameter name for the attribute.

   c. Select the **IsReadOnly** check box if Terminal Manager must only read attribute values from the corresponding SCADA parameter or process point parameter.
8 In the **Attribute Type** drop-down list, click **TransactionDetails**.
The window appears as follows.

![SCADA Attribute Configuration Window](image)

All the attributes for the transaction details are listed along with the details such as attribute code, parameter name, and so on.

9 To update the details for any attribute, select the attribute from the **Attribute Code** list, and then perform the following:

   a. Select the **IsProcessPoint** check box if the values must be updated by the process parameter. If this check box is cleared, the values are updated by SCADA.

   b. In the **Parameter Name** list, type the new parameter name for the attribute.

   c. Select the **IsReadOnly** check box if Terminal Manager must only read attribute values from the corresponding SCADA parameter or process point parameter.

10 Click **Save**.
The SCADA attribute configuration details for BCU are saved.

11 Repeat the above steps to configure SCADA attributes for virtual presets.
2.16 Configuring Truck SCADA

You can define the point parameter names that are used for a particular virtual preset controller present in the selected location type. The configuration that is generated for each virtual preset is saved into the corresponding BCU table in the “SCADA Configuration” column.

You can also generate a PNT for the selected virtual preset controller. However, for the process point attribute type, the PNT file generated does not have any references.

To configure truck SCADA

1. From the Standard Workflow Configuration Tool window, choose File > Transportation Type > ROAD.

2. Click the SCADAAttributeConfiguration tab. The window appears as follows.

3. In the BCU Code drop-down list, select the code of the BCU that you want to configure.
4 In the **Attribute Type** drop-down list, click **Device**. The window appears as follows.

All the device attributes for the selected BCU are listed along with the details such as attribute code, attribute description, parameter name, and so on. The values for fields such as **IsMandatory**, **DataType**, **IsActive**, and so on are displayed by default.

5 To update the details for any attribute, select the attribute from the **Attribute Code** list, and then perform the following:

   a. Select the **IsProcessPoint** check box if the values must be updated by the process parameter. If this check box is cleared, the values are updated by SCADA.

   b. In the **Parameter Name** list, type the new parameter name for the attribute.

   c. In the **Point Name** list, the point name is displayed by default. Type the new point name for the parameter.
6 In the **Attribute Type** drop-down list, click **TransactionPlan**. The window appears as follows.

![Image of the window](image)

All the transaction plan attributes for the selected BCU are listed along with the details such as attribute code, attribute description, parameter name, and so on.

7 To update the details for any attribute, select the attribute from the **Attribute Code** list, and then perform the following:

   a. Select the **IsProcessPoint** check box if the values must be updated by the process parameter. If this check box is cleared, the values are updated by SCADA.

   b. In the **Parameter Name** list, type the new parameter name for the attribute.

   c. In the **Point Name** list, the default point name is displayed. Type the new point name for the parameter.
8 In the **Attribute Type** drop-down list, click **TransactionDetails**. The window appears as follows.

![Attribute Type drop-down list](image)

All the transaction details attributes for the selected BCU are listed along with the details such as attribute code, parameter name, point name, and so on.

9 To update the details for any attribute, select the attribute from the **Attribute Code** list, and then perform the following:

   a. Select the **IsProcessPoint** check box if the values must be updated by the process parameter. If this check box is cleared, the values are updated by SCADA.

   b. In the **Parameter Name** list, type the new parameter name for the attribute.

   c. In the **Point Name** list, the default point name is displayed. Type the new point name for the parameter.

10 Click **Save**.
   The SCADA configuration details are saved. A configuration file containing the point parameter details for the selected BCU is generated and saved in the database.

11 Click **Generate PNT**.
   The **Save As** dialog box appears.

12 In the **File name** box, **SCADA** is displayed by default. If you want to change the name, enter a new name for the point file.
13 Click **Save**.  
A dialog box appears indicating that a point file for the BCU is generated.

14 Click **OK** to close the dialog box.

15 Repeat the above steps to configure SCADA for virtual presets.
2 – CONFIGURING WORKFLOW FOR ROAD TRANSPORTATION TYPE
3. Configuring Workflow for Contrec1010 BI/BJ and Contrec1030 DET

This section describes how to configure Terminal Manager for Contrec1010 BI/BJ and Contrec 1030 DET.
3.1 Configuring Site-wide Settings

You can configure the site-wide settings for the entities displayed in the Site Configuration tab.

To configure site-wide settings

1. From the Standard Workflow Configuration Tool window, click the Site Configuration tab.
   The following window appears with all the entities listed on the left pane.

2. On the left pane, click Driver under Entities.
   The following window appears.

3. Under Driver, select the source using which the driver is identified at the terminal. Under Identification Source, select one of the following:
   • PIN/Password: To identify the driver using a virtual PIN and password.
   • PIN: To identify the driver using only PIN.
   • Touch Key: To identify the driver using a touch key.
     The default value is PIN.
4 Under **Driver**, select the license of the driver, which must be a mandatory field on Terminal Manager. Under **Mandatory License(s)**, select one of the following:

- **License 1**: To make the driver’s license 1 details as mandatory on Terminal Manager.
- **License 2**: To make the driver’s license 2 details as mandatory on Terminal Manager.
- **License 3**: To make the driver’s license 3 details as mandatory on Terminal Manager.

5 On the left pane, click **Vehicle** under **Entities**. The following window appears.

6 Under **Vehicle**, select the source using which the vehicle is identified at the terminal. Under **Identification Source**, select one of the following:

- **PIN**: To identify the vehicle using a PIN.
- **Touch Key**: To identify the vehicle using a touch key.

The default value is **PIN**. A password is not required for vehicle identification.
7 On the left pane, click Reports under Entities.
The following window appears.

8 Under Reports, enter the following information:

- In the **FAN Report (Volume)** box, type the Filling Advisory Note (FAN) report name for volume-based shipments.
  The default FAN report name for volume-based shipments is **FANReportVolume**.

- In the **FAN Report (Weight)** box, type the FAN report name for weight-based shipments.
  The default FAN report name for weight-based shipments is **FANReportWeight**.

- In the **BOL Report** box, type the Bill of Lading (BOL) report name.
  The default BOL report name for shipments is **TMBOL**.

- In the **RAN Report (Volume)** box, type the Receipt Advisory Note (RAN) report name for volume-based receipts.
  The default RAN report name for volume-based receipts is **RANReportVolume**.

- In the **RAN Report (Weight)** box, type the RAN report name for weight-based receipts.
  The default RAN report name for weight-based receipts is **RANReportWeight**.

- In the BOD Report box, type the Bill of Discharge (BOD) report name.
  The default BOD report name for receipts is **TMBOD**.
9 On the left pane, click **Shipment** under **Entities**. The following window appears.

10 Under **Shipment**, select one of the following based on the maximum number of characters of finished product code that can be displayed on the BCU:

- **Product Code**: To display the finished product code on the BCU.
- **Product Index**: To display the finished product index on the BCU. The default value is Product Code.
11 On the left pane, click **Language** under **Entities**. The following window appears.

![Standard Workflow Configuration Tool]

12 Under **Language**, perform the following:

- From the **BCU** drop-down list, select the language in which the messages must be displayed on the BCU. For example: Select **en-US** to view the BCU messages in US English.

**Note**
- Ensure that the firmware supports language customization.
- If you want to select any other language, ensure that you first configure the required language in the Language page in Terminal Manager. The configured language is displayed in these drop-down lists.

- From the **Touch Screen** drop-down list, select the language in which the messages must be displayed on the PCDET. For example: Select **en-US** to view the PCDET messages in US English. The default value is **en-US**.
13 On the left pane, click **General** under **Entities**. The following window appears.

14 In the **SCADA Server Base Name** box, type the base name of the SCADA server. During Terminal Manager Box installation, this name is updated by default. However, you can update this name if required.

15 Select the **Tare Weight and Laden Weight to be measured on same weigh bridge** check box if you want to measure the tare weight and laden weight of a vehicle at the same weighbridge.

If the weighbridge used to measure the tare weight is not operational due to some issues (repair mode, communication issue, and so on), then you can measure the laden weight on any other weighbridge.

16 Click **Save**. The site-wide configuration is complete.
3.2 Configure Entry Gate Workflow

To configure entry gate workflow

1. From the Standard Workflow Configuration Tool window, click the Entry Gate tab.
   The entry gate window appears.

2. From the Entry Gate drop-down list, select the entry gate for which you want to configure various activities.
   The entry gates configured in the Site View Configuration page are listed.
   For example: EntryGate1
   The following window appears.

   The Driver Identification check box is selected by default for an entry gate.
   The entry gate workflow prompts for driver identification through PIN or touch key, as per the site-wide configuration.
After clicking **Driver Identification**, the following window appears.

4 Under **Driver**, select the license of the driver, for which you want to validate the expiry. Under **Driver Validations**, select one of the following:

- **License 1 Expiry**: To validate the expiry of driver’s license 1.
- **License 2 Expiry**: To validate the expiry of driver’s license 2.
- **License 3 Expiry**: To validate the expiry of driver’s license 3.

The mandatory validations such as whether the driver is valid, shareholder is active, and so on, are displayed on the lower half of the page.

5 Under **Operations**, click **Vehicle Identification**. The **Vehicle Identification** check box is selected by default. The entry gate workflow prompts for vehicle identification through PIN or touch key, as per the site-wide configuration.
After you click **Vehicle Identification**, the following window appears.

The mandatory validations such as whether the vehicle is valid, shareholder is active, and so on, are listed on the lower half of the page.

6 **Click Save.**

The entry gate workflow configuration is complete.
3.3 Configuring Loading Area Workflow

A bay is a location where loading and/or unloading operations happen in the terminal.

The terms bay and loading area refers to the same location. The loading area is represented as bay throughout the document.

You must configure the workflow for each bay.

**To configure bay workflow**

1. From the **Standard Workflow Configuration Tool** window, click the **Loading Area** tab.
   The loading area window appears.

2. From the **Loading Area** drop-down list, select the bay for which you want to configure various activities.
   The bays configured in the **Site View Configuration** page are listed.
   For example: Bay1
   The following window appears.

3. Under **Operations**, click **Driver Identification**.
   The **Driver Identification** check box is selected by default for a bay. The BCU prompts for driver identification through PIN or touch key, as per the site-wide configuration.
After you click **Driver Identification**, the following window appears.

![Driver Identification Window](image)

4 Under **Driver**, select the license of the driver, for which you want to validate the expiry. Under **Driver Validations**, select one of the following:

- **License 1 Expiry**: To validate the expiry of driver’s license 1.
- **License 2 Expiry**: To validate the expiry of driver’s license 2.
- **License 3 Expiry**: To validate the expiry of driver’s license 3.

The mandatory validations such as whether the driver is valid, shareholder is active, and so on, are displayed on the lower half of the page.

5 Under **Operations**, click **Vehicle Identification**.
The **Vehicle Identification** check box is selected by default.
After you click **Vehicle Identification**, the following window appears.

![Window display](image)

The mandatory validations such as whether the vehicle is valid, shareholder is active, and so on, are listed on the lower half of the page.

6 **Under Operations**, click **Shipment Identification**.

The **Shipment Identification** check box is selected by default. The workflow prompts for shipment selection and/or confirmation, as per the shipment validation configurations.
After you click **Shipment Identification**, the following window appears.

7 Under **Shipment Source Selection**, the **Shipment By Compartment** check box is selected by default. However, if required, you can also select the **Contract** check box to create shipments from a contract, at the bay.  
Under **Mode of Selection**, the **Enter Shipment Code** option is selected by default.

8 Under **Shipment Input Status**, select the statuses of the shipments, based on which the driver can view the shipments. 
The default shipment input statuses are **PARTIALLY_LOADED** and **READY**.

9 Under **Operations**, click **Shipment Validation**. 
The **Shipment Validation** check box is selected by default and is unavailable for editing.
After you click **Shipment Validations**, the following window appears.

10 Under **Shipment Validations**, perform the following:

a. Select the **Driver - Vehicle belongs to same carrier** check box if the driver and the vehicle for a shipment must belong to the same carrier company.

b. Select the **Schedule date valid** check box, if you want to specify the duration for which the shipment can be viewed or selected by the driver at this bay.

If you select the check box, the **Date range (+/-) days** box is available for editing. Type a value determining the range for which the shipment is valid.

For example: If the value for the field **Date range (+/-) days** is set to 2 and if the scheduled date is January 10, the driver can view or select the shipments that are scheduled between January 8th (two days earlier than the scheduled date) and January 12th (two days later than the scheduled date).

11 Under **Operations**, click **Shipment Close**. You can select this option when there is no exit gate in the terminal and the shipment must be closed automatically by the workflow on successful loading as per the shipment plan.
The following window appears.

12 Under **Report Options**, select the **Print BOL** check box if you want to print a Bill of Lading (BOL) report after a shipment is successfully loaded at the bay.

13 Under **Operations**, click **Compartment Plan**.
   The following window appears.
14 Under **Compartment Plan Options**, select the **Download Density** check box if you want to download the density values to the BCU.

15 Under **Operations**, click **Monitor Loading**. The following window appears.

16 Under **Monitor Load Options**, the following check boxes are selected by default.

- **Flow Rate**: To monitor the flow rate of the product during loading.
- **Temperature**: To monitor the temperature of the product during loading.
- **Density**: To monitor the density of the product during loading.
- **Pressure**: To monitor the pressure of the product during loading.
- **Mass**: To monitor the mass of the product during loading.

If you do not want to monitor any or all of these details, you can clear any or all of these check boxes.
17 Under Operations, click Leakage.
The following window appears.

18 Select the Before Loading check box to capture the leakage details of the loading arm, before the loading of product begins.

19 Under Operations, select the Local Loading check box, if you want to upload the locally loaded transaction details to the Terminal Manager database.

20 Click Save.
The loading area workflow configuration is complete.
3.4 Configuring Exit Gate Workflow

An exit gate is a location where the vehicle exits the terminal after completion of
loading. An exit gate may include operations pertaining to BOL office (if a BOL
office location is not configured. The validations for driver, vehicle, and shipment
are performed at an exit gate.

You can configure the workflow for the exit gate.

To configure exit gate workflow

1. From the Standard Workflow Configuration Tool window, click the Exit
Gate tab.
   The exit gate window appears.

2. From the Exit Gate drop-down list, select the exit gate for which you want to
   configure various activities.
   The exit gates configured in the Site View Configuration page are listed.
   For example: ExitGate1
   The following window appears.

   The Driver Identification check box is selected by default for an exit gate.
   The exit gate workflow prompts for driver identification through PIN or touch
   key, as per the site-wide configuration.
After you click **Driver Identification**, the following window appears.

![Diagram of the interface](image)

4 Under **Driver**, select the license of the driver, for which you want to validate the expiry. Under **Driver Validations**, select one of the following:

- **License 1 Expiry**: To validate the expiry of driver’s license 1.
- **License 2 Expiry**: To validate the expiry of driver’s license 2.
- **License 3 Expiry**: To validate the expiry of driver’s license 3.

The mandatory validations such as whether the driver is valid, shareholder is active, and so on, are displayed on the lower half of the page.

5 Under **Operations**, click **Vehicle Identification**.

The **Vehicle Identification** check box is selected by default. The exit gate workflow prompts for vehicle identification through PIN or touch key, as per the site-wide configuration.
After you click **Vehicle Identification**, the following window appears.

![Vehicle Identification Window]

The mandatory validations such as whether the vehicle is valid, shareholder is active, and so on, are displayed on the lower half of the page.

6 Under **Operations**, click **Shipment Identification**. The **Shipment Identification** check box is selected by default. The exit gate workflow prompts for shipment selection, as per the shipment validation configurations.
After you click **Shipment Identification**, the following window appears.

7 Select the **Print BOL** check box if you want to print the bill of lading report.

8 Under **Shipment Input Status**, select the statuses of the shipments, based on which the driver can view the shipments. For example: If the input status is selected as **AUTO LOADED** and **MANUALLY LOADED**, the driver can view or select only the shipments that are in **AUTO LOADED** or **MANUALLY LOADED** states. The default shipment input statuses are **AUTO LOADED** and **MANUALLY LOADED**.

9 Click **Save**. The exit gate workflow configuration is complete.
You can configure the SCADA parameter names based on the location type. The configured values are common for all virtual preset controllers existing in the particular location.

You can define the SCADA parameter names for all the attributes based on the location type. You can define whether the attribute value is taken from SCADA or process point parameter, define the data type of the SCADA attribute, and also make any attributes inactive if not being used.
4.1 Configuring Pipeline Virtual Preset SCADA Attributes

To configure pipeline virtual preset SCADA attributes

1. From the **Standard Workflow Configuration Tool** window, choose **File > Transportation Type > PIPELINE**.
   The window appears as follows with the **SCADAAttributeConfiguration** tab selected by default.
2 In the **Attribute Type** drop-down list, click **Device**.
The window appears as follows.

All the attributes for the pipeline header are listed along with the details such as attribute code, attribute description, parameter name, and so on. The values for fields such as **IsMandatory**, **DataType**, **IsActive**, and so on are displayed by default.

3 To update the details for any attribute, select the attribute from the **Attribute Code** list, and then perform the following:

   a. Select the **IsProcessPoint** check box if the values must be updated by the process point. If this check box is cleared, the values are updated by SCADA.

   b. In the **Parameter Name** list, type the new parameter name for the attribute.

   c. Select the **IsReadOnly** check box if Terminal Manager must only read attribute values from the corresponding SCADA parameter or process point parameter.

4 In the **Attribute Type** drop-down list, click **TransactionPlan**.
All the attributes for the transaction plan are listed along with the details such as attribute code, parameter name, and so on.

To update the details for any attribute, select the attribute from the Attribute Code list, and then perform the following:

a. Select the IsProcessPoint check box, if the values must be updated by the process parameter. If this check box is cleared, the values are updated by SCADA.

b. In the Parameter Name list, type the new parameter name for the attribute.

c. Select the IsReadOnly check box, if Terminal Manager must only read attribute values from the corresponding SCADA parameter or process point parameter.
6 In the **Attribute Type** drop-down list, click **TransactionDetails**. The window appears as follows.

All the attributes for the transaction details are listed along with the details such as attribute code, parameter name, and so on.

7 To update the details for any attribute, select the attribute from the **Attribute Code** list, and then perform the following:

   a. Select the **IsProcessPoint** check box, if the values must be updated by the process parameter. If this check box is cleared, the values are updated by SCADA.

   b. In the **Parameter Name** list, type the new parameter name for the attribute.

   c. Select the **IsReadOnly** check box, if Terminal Manager must only read attribute values from the corresponding SCADA parameter or process point parameter.

8 Click **Save**. The SCADA attribute configuration details for pipeline virtual preset are saved.
4.2 Configuring Pipeline Virtual Preset

You can define the point parameter names that are used for a particular virtual preset controller present in the selected location type. The configuration that is generated for each virtual preset is saved into the corresponding Pipeline table in the “SCADA Configuration” column.

You can also generate a PNT for the selected pipeline. However, for the process point attribute type, the PNT file generated does not have any references.

To configure pipeline virtual preset SCADA

1. From the Standard Workflow Configuration Tool window, choose File > Transportation Type > PIPELINE.
2. Click the SCADA Configuration tab is selected by default. The window appears as follows.

3. In the BCU Code drop-down list, select the code of the pipeline header that you want to configure.
4 In the **Attribute Type** drop-down list, click **Device**. The window appears as follows.

All the device attributes for the selected pipeline virtual preset are listed along with the details such as attribute code, attribute description, parameter name, and so on. The values for fields such as **IsMandatory**, **DataType**, **IsActive**, and so on are displayed by default.

5 To update the details for any attribute, select the attribute from the **Attribute Code** list, and then perform the following:

   a. Select the **IsProcessPoint** check box, if the values must be updated by the process parameter. If this check box is cleared, the values are updated by SCADA.

   b. In the **Parameter Name** list, type the new parameter name for the attribute.

   c. In the **Point Name** list, the default point name is displayed. Type the new point name for the parameter.
6 In the **Attribute Type** drop-down list, click **TransactionPlan**. The window appears as follows.

![Window showing SCADA Attribute Configuration with TransactionPlan selected](image)

All the transaction plan attributes for the selected pipeline virtual preset are listed along with the details such as attribute code, attribute description, parameter name, and so on.

7 To update the details for any attribute, select the attribute from the **Attribute Code** list, and then perform the following:

   a. Select the **IsProcessPoint** check box, if the values must be updated by the process parameter. If this check box is cleared, the values are updated by SCADA.
   
   b. In the **Parameter Name** list, type the new parameter name for the attribute.
   
   c. In the **Point Name** list, the default point name is displayed. Type the new point name for the parameter.
8 In the **Attribute Type** drop-down list, click **TransactionDetails**. The window appears as follows.

![Screen capture of Standard Workflow Configuration Tool]

All the transaction details attributes for the selected pipeline virtual preset are listed along with the details such as attribute code, parameter name, point name, and so on.

9 To update the details for any attribute, select the attribute from the **Attribute Code** list, and then perform the following:

   a. Select the **IsProcessPoint** check box, if the values must be updated by the process parameter. If this check box is cleared, the values are updated by SCADA.

   b. In the **Parameter Name** list, type the new parameter name for the attribute.

   c. In the **Point Name** list, the default point name is displayed. Type the new point name for the parameter.

10 Click **Save**. The pipeline virtual preset configuration details are saved.

11 Click **Generate PNT**. The **Save As** dialog box appears.

12 In the **File name** box, **SCADA** is displayed by default. If you want to change the name, enter a new name for the point file.
13 Click Save. 
   A dialog box appears indicating that a point file for the virtual preset is generated.

14 Click OK to close the dialog box.
5. Configuring Workflow for Marine Transportation Type

This chapter describes the configuration workflow for marine transportation.
5.1 Configuring Marine Site-wide Settings

You can configure the marine site-wide settings for the entities displayed in the Site Configuration tab.

To configure marine site-wide settings

1. From the Standard Workflow Configuration Tool window, choose File > Transportation Type > MARINE.
   The window appears as follows. The SiteConfiguration tab is selected by default with all the entities listed on the left pane.

2. On the left pane, click Reports under Entities.
   The following window appears.

3. Under Reports, enter the following information:
   • In the FAN Report box, type the Filling Advisory Note (FAN) report name for marine shipments.
The default FAN report name for marine shipments is \textit{MarineFAN}.

- In the \textbf{BOL Report} box, type the Bill of Lading (BOL) report name. The default BOL report name for shipments is \textit{MarineBOL}.

- In the \textbf{RAN Report} box, type the Receipt Advisory Note (RAN) report name for marine receipts. The default RAN report name for volume-based receipts is \textit{MarineRAN}.

- In the \textbf{BOD Report} box, type the Bill of Discharge (BOD) report name. The default BOD report name for receipts is \textit{MarineBOD}.

4. On the left pane, click \textbf{Finished Product} under \textbf{Entities}. The window appears as follows.

5. Under \textbf{Shipment}, select one of the following based on the maximum number of characters of finished product code that can be displayed on the BCU:
   - \textbf{Product Code}: To display the finished product code on the BCU.
   - \textbf{Product Index}: To display the finished product index on the BCU. The default value is Product Code.
6 On the left pane, click **Language** under **Entities**. The window appears as follows.

![Language Configuration Window](image)

7 From the **BCU** drop-down list, select the language in which the messages must be displayed on the BCU. For example: Select **en-US** to view the BCU messages in US English.

**Note**
- Ensure that the firmware supports language customization.
- If you want to select any other language, ensure that you first configure the required language in the Language page in Terminal Manager. The configured language is displayed in these drop-down lists.

8 On the left pane, click **Officer** under **Entities**. The window appears as follows.
9 Under **Officer**, select the source using which the officer is identified at the terminal. Under **Identification Source**, select one of the following:

- **Access Card**: To identify the officer using an electronic proximity access card.
- **PIN**: To identify the officer using a PIN and password. The default value is **PIN**.

10 Click **Save**.

The marine site-wide configurations are complete.
5.2 Configuring Marine Loading Area Workflow

A marine bay also known as a berth is a location where loading and/or unloading operations happen in the terminal.

You must configure the workflow for each berth. The possible devices available at the berth are the BCUs and virtual presets.

To configure marine loading area workflow

1. From the Standard Workflow Configuration Tool window, choose File > Transportation Type > MARINE. The SiteConfiguration tab is selected by default.
2. From the Standard Workflow Configuration Tool window, click the MarineLoadingArea tab. The marine loading area window appears.
3. From the Marine Bay drop-down list, select the berth for which you want to configure various activities. The berths configured in the Site View Configuration page are listed. For example: Berth1. The following window appears.

   ![Image of Marine Loading Area Workflow Configuration Tool]

4. Under Operations, click Officer Identification. The Officer Identification check box is selected by default for a berth. The BCU prompts for officer identification through access card or PIN- password, as per the site-wide configuration.
5 Under Operations, click Shipment Identification. The Shipment Identification check box is selected by default. The workflow prompts for shipment selection and/or confirmation, as per the shipment validation configurations. After you click Shipment Identification, the following window appears.

![Shipment Identification Window](image)

Under Shipment Source Selection, the following details are displayed by default and are unavailable for editing.

- **Shipment By Compartment**: The marine shipments available for the identified officer, at the berth can be viewed.
- **Enter Shipment Code**: The officer must enter the shipment code to select the shipment.

6 Under Shipment Input Status, select the statuses of the shipments, based on which the officer can view the shipments. The default shipment input statuses are and PARTIALLY_LOADED and QUEUED.

7 Under Operations, click Shipment Validation. The Shipment Validation check box is selected by default.

8 Under Shipment Validations, select the Schedule date valid check box, if you want to specify the duration for which the shipment can be viewed or selected by the officer at this marine bay. If you select the check box, the Date range (+/-) days box is available for editing. Type a value determining the range for which the shipment is valid. For example: If the value for the field Date range (+/-) days is set to 2 and if the scheduled date is January 10, the officer can view or select the shipments.
that are scheduled between January 8th (two days earlier than the scheduled date) and January 12th (two days later than the scheduled date).

9 Under Operations, click Compartment Plan. The Compartment Plan check box is selected by default. After you click Compartment Plan, the following window appears.

10 Under Compartment Options, select one of the following:

- **Confirm Compartment Number**: If the officer must confirm the compartment number in which the product must be loaded.
- **Enter Compartment Number**: If the officer must enter the compartment number in which the product must be loaded.

11 Under Compartment Plan Options, perform the following:

- Select the **Check Permissives** check box.
- Select the **Remote Start** check box, if the BCU supports remote start of loading.
- Select the **Allow Density** check box if, the density value must be downloaded to the BCU.
- Select the **Return Quantity** check box if, the officer must enter the return quantity.
12 Under **Loading Arm Options**, select one of the following:
   - **Confirm Arm Number** option if you want to confirm the selected arm for loading.
   - **Change Loading Arm** option if a different loading arm can be used instead of the planned loading arm.

13 Under **Operations**, click **Shipment Close**. You can select this option when there is no exit gate in the terminal and the shipment must be closed automatically by the workflow on successful loading as per the shipment plan. The following window appears.

14 Under **Report Options**, select the **Print BOL** check box if you want to print a Bill of Lading (BOL) report after a marine shipment is successfully loaded at the berth.
15 Under **Operations**, click **Monitor Loading**.  
The following window appears.

![Monitor Loading Window](image)

16 Under **Monitor Load Options**, the following check boxes are selected by default.

- **Flow Rate**: To monitor the flow rate of the product during loading.
- **Temperature**: To monitor the temperature of the product during loading.
- **Density**: To monitor the density of the product during loading.
- **Pressure**: To monitor the pressure of the product during loading.
- **Mass**: To monitor the mass of the product during loading.

If you do not want to monitor any or all of these details, you can clear any or all of these check boxes.

17 Under **Operations**, click **Leakage**.

18 Select the **Before Loading** check box to capture the leakage details of the loading arm, before the loading of product begins.
19 Under **Operations**, select the **Local Loading** check box, if you want to upload the locally loaded transaction details to the Terminal Manager database.

**Note**

- Ensure that you do not select the **Receipt Identification** and **Receipt Validation** check boxes and skip steps 20 to 32 for the following:
  - If the bay loading type is “Top”.
  - If the BCU type is “Accuload-III or Accuload-IV”

20 Under **Operations**, click **Receipt Identification**. The **Receipt Identification** check box is selected by default. The workflow prompts for receipt selection and/or confirmation, as per the receipt validation configurations.

After you click **Receipt Identification**, the following window appears.

21 Under **Receipt Source Selection**, select the **Receipt by Compartment** check box if you want to view receipts available for the identified officer, at the berth.

22 Under **Mode of Selection**, ensure that you select **Enter Receipt Code**. The officer must enter the receipt code to select the receipt.

**Note**

The current release of Terminal Manager supports only the **Enter Receipt Code** option.
23 Under **Receipt Input Status**, select the statuses of the receipt, based on which the officer can view the receipts. The default receipt input statuses are QUEUED and PARTIALLY UNLOADED.

24 Under **Operations**, click **Receipt Validations**. The **Receipt Validations** check box is selected by default.

25 Under **Receipt Validations**, select the **Schedule date valid** check box, if you want to specify the duration for which the receipt can be viewed or selected by the officer at this berth. If you select the check box, the **Date range (+/-) days** box is available for editing. Type a value determining the range for which the receipt is valid. For example: If the value for the field **Date range (+/-) days** is set to 2 and if the scheduled date is January 10, the officer can view or select the receipts that are scheduled between January 8th (two days earlier than the scheduled date) and January 12th (two days later than the scheduled date).

26 Under **Operations**, click **Receipt Compartment Plan**. The following window appears.

27 Under **Compartment Plan Options**, perform the following:

- Select the **Check Permissives** check box.
- Select the **Allow Density** check box if the density value must be downloaded to the BCU.
28 Under **Compartment Options**, select one of the following:

- **Confirm Compartment Number**: If the officer must confirm the compartment number from which the product must be unloaded.
- **Enter Compartment Number**: If the officer must enter the compartment number from which the product must be unloaded.

29 Under **Unloading Arm Options**, select one of the following:

- **Change Unloading Arm** option if a different unloading arm can be used instead of the planned unloading arm.
- **Confirm Unloading Arm** option if you want to confirm the selected arm for unloading.

30 Under **Operations**, select the Local **UnLoading** check box, if you want to upload the locally unloaded transaction details to the Terminal Manager database.

31 Under **Operations**, click **Receipt Close**. You can select this option when there is no exit gate in the terminal and the receipt must be closed automatically by the workflow on successful unloading as per the receipt plan. The following window appears.

32 Under **Report Options**, select the **Print BOD** check box if you want to print a Bill of Discharge (BOD) report after a receipt is successfully unloaded at the berth.

33 Click **Save**.
   The marine loading area workflow configuration is complete.
5.3 Configuring Notification Messages for BCU DIDO and Swing Arm Input

You can configure the notification messages for Digital Input and Digital Output (DIDO) for each BCU configured in site view.

You can also configure general programmable input number (PIN) for swing arms. This indicates the PIN in the BCU to which the swing arm is connected.

For example: If the swing arm position input is connected to the BCU input board connectors “CA25[In+]/CA24[In-]”, then you must enter the Arm Position GP Input as “5”.

Note

- DIDO messages are applicable only for Accuload-III, Accuload-IV, Contrec 1010CB, Contrec 1010CJ, and MSC-L, Multiload-II BCUs.
- Swing arm feature is applicable only for Contrec 1010CB and Contrec 1010CJ BCUs.
- The steps to configure BCU DIDOs for marine site view are similar to the steps to configure BCU DIDOs for truck site view.
  For more information about configuring DIDO for BCUs, refer to “Configuring Notification Messages for DIDO and Swing Arm Input”.
5.4 Configuring Recipes

A recipe is a pure base product or a blend of two or more base products or a base product and one or more additives. You can configure the recipe numbers for each finished product.

Note
Recipe configuration is applicable only for Accuload-III, Multiload-II, MSC-L and Contrec 1010CB BCUs.

In case of Multiload-II, Component and Additive Index should be specified as per the device configuration.

The steps to configure recipes for marine site view are similar to the steps to configure recipes for truck site view.

For more information about configuring recipes, refer to “Configuring Recipes”.
5.5 Configuring Marine SCADA Attributes

You can define the point parameter names that are used for a particular BCU and/or virtual preset controller present in the selected location type. The configuration that is generated for each BCU and/or virtual preset is saved into the corresponding BCU table in the “SCADA Configuration” column.

You can also generate a PNT for the selected BCU and/or virtual preset controller. However, for the process point attribute type, the PNT file generated does not have any references.

To configure SCADA attributes

1. From the Standard Workflow Configuration Tool window, choose File > Transportation Type > MARINE.
2. Click the SCADAAttributeConfiguration tab. The window appears as follows.

3. In the Type drop-down list, click BCU to configure the SCADA attributes for BCU.
4 In the **Attribute Type** drop-down list, click **Device**. The window appears as follows.

All the device attributes for the selected BCU are listed along with the details such as attribute code, attribute description, parameter name, and so on. The values for fields such as **IsMandatory**, **DataType**, **IsActive**, and so on are displayed by default.

5 To update the details for any attribute, select the attribute from the **Attribute Code** list, and then perform the following:

- Select the **IsProcessPoint** check box, if the values must be updated by the process parameter. If this check box is cleared, the values are updated by SCADA.
- In the **Parameter Name** list, type the new parameter name for the attribute.
- Select the **IsReadOnly** check box, if Terminal Manager must only read attribute values from the corresponding SCADA parameter or process point parameter.
In the **Attribute** Type drop-down list, click **TransactionPlan**. The window appears as follows.

All the transaction plan attributes for the selected BCU are listed along with the details such as attribute code, attribute description, parameter name, and so on.

To update the details for any attribute, select the attribute from the **Attribute Code** list, and then perform the following:

- Select the **IsProcessPoint** check box, if the values must be updated by the process parameter. If this check box is cleared, the values are updated by SCADA.
- In the **Parameter Name** list, type the new parameter name for the attribute.
- Select the **IsReadOnly** check box, if Terminal Manager must only read attribute values from the corresponding SCADA parameter or process point parameter.
In the **Attribute Type** drop-down list, click **TransactionDetails**. The window appears as follows.

All the transaction details attributes for the selected BCU are listed along with the details such as attribute code, parameter name, point name, and so on.

To update the details for any attribute, select the attribute from the **Attribute Code** list, and then perform the following:

- Select the **IsProcessPoint** check box, if the values must be updated by the process parameter. If this check box is cleared, the values are updated by SCADA.
- In the **Parameter Name** list, type the new parameter name for the attribute.
- Select the **IsReadOnly** check box, if Terminal Manager must only read attribute values from the corresponding SCADA parameter or process point parameter.

Click **Save**.

The SCADA configuration details are saved. A configuration file containing the point parameter details for the selected BCU is generated and saved in the database.

Repeat the above steps to configure SCADA attributes for virtual preset.
5.6 Configuring Marine SCADA

You can define the point parameter names that are used for a particular BCU and/or virtual preset controller present in the selected location type. The configuration that is generated for each BCU and/or virtual preset is saved into the corresponding BCU table in the “SCADA Configuration” column.

You can also generate a PNT for the selected BCU and/or virtual preset controller. However, for the process point attribute type, the PNT file generated does not have any references.

To configure marine SCADA

1. From the Standard Workflow Configuration Tool window, choose File > Transportation Type > MARINE.

2. Click the SCADAAttributeConfiguration tab. The window appears as follows.

3. In the BCU Code drop-down list, select the code of the BCU for which you want to configure SCADA.
4 In the **Attribute Type** drop-down list, click **Device**. The window appears as follows.

All the device attributes for the selected BCU are listed along with the details such as attribute code, attribute description, parameter name, and so on. The values for fields such as **IsMandatory**, **DataType**, **IsActive**, and so on are displayed by default.

5 To update the details for any attribute, select the attribute from the **Attribute Code** list, and then perform the following:

   a. Select the **IsProcessPoint** check box, if the values must be updated by the process parameter. If this check box is cleared, the values are updated by SCADA.

   b. In the **Parameter Name** list, type the new parameter name for the attribute.

   c. In the **Point Name** list, the default point name is displayed. Type the new point name for the parameter.
6 In the Attribute Type drop-down list, click TransactionPlan. The window appears as follows.

![Standard Workflow Configuration Tool](image)

All the transaction plan attributes for the selected BCU are listed along with the details such as attribute code, attribute description, parameter name, and so on.

7 To update the details for any attribute, select the attribute from the Attribute Code list, and then perform the following:
   a. Select the IsProcessPoint check box, if the values must be updated by the process parameter. If this check box is cleared, the values are updated by SCADA.
   b. In the Parameter Name list, type the new parameter name for the attribute.
   c. In the Point Name list, the default point name is displayed. Type the new point name for the parameter.
In the **Attribute Type** drop-down list, click **TransactionDetails**. The window appears as follows.

All the transaction details attributes for the selected BCU are listed along with the details such as attribute code, parameter name, point name, and so on.

To update the details for any attribute, select the attribute from the **Attribute Code** list, and then perform the following:

a. Select the **IsProcessPoint** check box, if the values must be updated by the process parameter. If this check box is cleared, the values are updated by SCADA.

b. In the **Parameter Name** list, type the new parameter name for the attribute.

c. In the **Point Name** list, the default point name is displayed. Type the new point name for the parameter.

Click **Save**. The SCADA configuration details are saved. A configuration file containing the point parameter details for the selected BCU is generated and saved in the database.

Click **Generate PNT**. The **Save As** dialog box appears.

In the **File name** box, **SCADA** is displayed by default. If you want to change the name, enter a new name for the point file.
13  Click Save.  
A dialog box appears indicating that a point file for the BCU is generated.
14  Click OK to close the dialog box.
15  Repeat the steps to configure SCADA for virtual presets.
6. Configuring Workflow for Rail Transportation

This chapter describes the configuration workflow for rail transportation.
6.1 Configuring Rail Site-wide Settings

You can configure the rail site-wide settings for the entities displayed in the Site Configuration tab.

To configure rail site-wide settings

1. From the Standard Workflow Configuration Tool window, choose File > Transportation Type > RAIL. The window appears as follows.

The SiteConfiguration tab is selected by default with all the entities listed on the left pane.
2 On the left pane, click **Reports** under **Entities**.
The following window appears.

![Image of the window](image.png)

3 Under **Reports**, enter the following information:

- In the **FAN Report** box, type the Filling Advisory Note (FAN) report name for rail dispatches.
  The default FAN report name for marine shipments is **RailFAN**.

- In the **BOL Report** box, type the Bill of Lading (BOL) report name.
  The default BOL report name for rail dispatches is **RailBOL**.

- In the **RAN Report** box, type the Receipt Advisory Note (RAN) report name for rail receipts.
  The default RAN report name for volume-based receipts is **RailRAN**.

- In the **BOD Report** box, type the Bill of Discharge (BOD) report name.
  The default BOD report name for rail receipts is **RailBOD**.
4 On the left pane, click **Finished Product** under **Entities**. The following window appears.

5 Under **Shipment**, select one of the following based on the maximum number of characters of finished product code that can be displayed on the BCU:

   - **Product Code**: To display the finished product code on the BCU.
   - **Product Index**: To display the finished product index on the BCU.
   
   The default value is **Product Code**.
On the left pane, click **Language** under **Entities**. The following window appears.

From the **BCU** drop-down list, select the language in which the messages must be displayed on the BCU.

For example: Select **en-US** to view the BCU messages in US English.

**Note**

- Ensure that the firmware supports language customization.
- If you want to select any other language, ensure that you first configure the required language in the Language page in Terminal Manager. The configured language is displayed in these drop-down lists.
8 On the left pane, click Officer under Entities. The following window appears.

9 Under Officer, select the source using which the officer is identified at the terminal. Under Identification Source, select one of the following:

- **Access Card**: To identify the officer using an electronic proximity access card.
- **PIN**: To identify the officer using a PIN and password. The default value is PIN.

10 Click Save.
The rail site-wide configurations are complete.
6.2 Configuring Rail Loading Area Workflow

A rail loading area also known as a cluster is a location where loading and/or unloading operations happen in the terminal.

You must configure the workflow for each cluster. The possible devices available at the cluster are the BCUs and virtual presets. The BCU itself is used as a HMI. Therefore, a PCDET is not supported in this location.

To configure rail loading area workflow

1  From the Standard Workflow Configuration Tool window, choose File > Transportation Type > RAIL. The window appears as follows with the SiteConfiguration tab selected by default.

2  Click the Cluster tab. The cluster window appears.

3  From the Cluster drop-down list, select the cluster for which you want to configure various activities. The clusters configured in the Site View Configuration page are listed.
For example: Cluster02
The following window appears.

4 Under **Operations**, click **Officer Identification**.
The **Officer Identification** check box, is selected by default for a cluster. The BCU prompts for officer identification through access card or PIN- password, as per the site-wide configuration.

5 Under **Operations**, click **Dispatch Identification**.
The **Dispatch Identification** check box is selected by default. The workflow prompts for dispatch selection and/or confirmation, as per the dispatch validation configurations.
After you click **Dispatch Identification**, the following window appears.

6 Under **Dispatch Source Selection**, select the **Dispatch By Compartment** check box to view the rail dispatches available for the identified officer, at the rail cluster.

7 Choose any one of the following under **Mode of Selection**.
   - **Enter Dispatch Code**: The officer must enter the dispatch code to select the dispatch.
   - **Confirmed Dispatch**: The officer must confirm the dispatch for the identified officer.
8 Under **Operations**, click **Dispatch Validation**. The **Dispatch Validation** check box is selected by default. After you click Dispatch Validation, the following window appears.

![Dispatch Validation Window](image)

9 Under **Dispatch Validations**, select the **Schedule date valid** check box, if you want to specify the duration for which the dispatch can be viewed or selected by the officer at this rail cluster. If you select the check box, the **Date range (+/-) days** box is available for editing. Type a value determining the range for which the dispatch is valid. For example: If the value for the field **Date range (+/-) days** is set to 2 and if the scheduled date is January 10, the officer can view or select the dispatches that are scheduled between January 8th (two days earlier than the scheduled date) and January 12th (two days later than the scheduled date).
10 Under Operations, click Dispatch Wagon Plan. The Dispatch Wagon Plan check box is selected by default. After you click Dispatch Wagon Plan, the following window appears.

11 Under Wagon Options, select one of the following:
   • Confirm Wagon Number: If the officer must confirm the wagon number in which the product must be loaded.
   • Enter Wagon Code: If the officer must enter the wagon code in which the product must be loaded.

12 Under Loading Arm Options, select one of the following:
   • Confirm Arm Number option, if you want to confirm the selected arm for loading.
   • Change Loading Arm option, if a different loading arm can be used instead of the planned loading arm.
13 Under Wagon Plan Options, perform the following:
   • Select the Check Permissives check box.
   • Select the Remote Start check box, if the BCU supports remote start of loading.
   • Select the Allow Density check box, if the density value must be downloaded to the BCU.
   • Select the Enter Return Quantity check box, if the officer must enter the return quantity.
   • Select the Replan Preset Quantity check box, if the officer must re-plan the preset quantity.

14 Under Operations, click Receipt Identification. The Receipt Identification check box is selected by default. The workflow prompts for receipt selection and/or confirmation, as per the receipt validation configurations. After you click Receipt Identification, the following window appears.

15 Choose any one of the following under Mode of Selection.
   • Enter Code: The officer must enter the receipt code to select the receipt.
   • Confirmed receipt: The officer must confirm the receipt for the identified officer.
Under Receipt Input Status, the default receipt input status is displayed as CHECKED_IN and is unavailable for editing.
16 Under **Operations**, click **Receipt Validation**.
The **Receipt Validation** check box is selected by default.
After you click **Receipt Validation**, the following window appears.

17 Under **Receipt Validations**, select the **Schedule date valid** check box, if you want to specify the duration for which the receipt can be viewed or selected by the officer at this rail cluster.
If you select the check box, the **Date range (+/ -) days** box is available for editing. Type a value determining the range for which the receipt is valid.
For example: If the value for the field **Date range (+/ -) days** is set to 2 and if the scheduled date is January 10, the officer can view or select the receipts that are scheduled between January 8th (two days earlier than the scheduled date) and January 12th (two days later than the scheduled date).
18 Under **Operations**, click **Receipt Wagon Plan**. The **Receipt Wagon Plan** check box is selected by default. After you click **Receipt Wagon Plan**, the following window appears.

19 Under **Wagon Options**, select one of the following:

- **Confirm Wagon Number**: If the officer must confirm the wagon number in which the product must be loaded.
- **Enter Wagon Code**: If the officer must enter the wagon code in which the product must be loaded.

20 Under **Loading Arm Options**, select one of the following:

- **Confirm Loading Arm** option if you want to confirm the selected arm for unloading.
- **Change Loading Arm** option if a different loading arm can be used instead of the planned unloading arm.

21 Under **Wagon Plan Options**, perform the following:

- Select the **Check Permissives** check box.
- Select the **Allow Density** check box if the density value must be downloaded to the BCU.
22 Under **Operations**, click **Monitor Loading**. The following window appears.

![Monitor Loading Options Window](image)

23 Under **Monitor Load Options**, the following check boxes are selected by default.

- **Flow Rate**: To monitor the flow rate of the product during loading.
- **Temperature**: To monitor the temperature of the product during loading.
- **Density**: To monitor the density of the product during loading.
- **Pressure**: To monitor the pressure of the product during loading.
- **Mass**: To monitor the mass of the product during loading.

24 For Accuload-III, Accuload-IV, Contrec 1010CB, or Contrec 1010CJ BCUs, skip to step 25.

Or

For MSC-L BCUs, perform step 2524.
25 For MSC-L BCU, select any or all of the following check boxes:

- **CAN-IN-OUT-MSC Board 1**: To monitor the DIDO configurations for the following points: DI_DC_1 till DI_DC_15, DI_AC_1 till DI_AC_3, DO_EMR_1 till DO_EMR_10, DO_SSR_13 till DO_SSR_16
- **CAN-IN-OUT-MSC Board 2**: To monitor the DIDO configurations for the following points: DI_DC_16 till DI_DC_30, DI_AC_4 till DI_AC_6, DO_EMR_11 till DO_EMR_20, DO_SSR_17 till DO_SSR_20
- **CAN-IN-OUT-MSC Board 3**: To monitor the DIDO configurations for the following points: DI_DC_31 till DI_DC_45, DI_AC_7 till DI_AC_9, DO_EMR_21 till DO_EMR_30, DO_SSR_33 till DO_SSR_36
- **CAN-IN-OUT-MSC Board 4**: To monitor the DIDO configurations for the following points: DI_DC_46 till DI_DC_60, DI_AC_10 till DI_AC_12, DO_EMR_31 till DO_EMR_40, DO_SSR_37 till DO_SSR_40
- **CAN-ARM-MSC Board 1**: To monitor the DIDO configurations for the following points: DO_SSR_1 till DO_SSR_12
- **CAN-ARM-MSC Board 2**: To monitor the DIDO configurations for the following points: DO_SSR_21 till DO_SSR_32

If you do not want to monitor any or all of these details, you can clear any or all of these check boxes.

26 Under **Operations**, click **Leakage**. The following window appears.

27 Select the **Before Loading** check box, to capture the leakage details of the loading arm, before the loading of product begins.
28 Under **Operations**, select the **Local Loading** check box, if you want to upload the locally loaded transaction details to the Terminal Manager database.

29 Click **Save**.

The rail loading area workflow configuration is complete.
6.3 Configuring Notification Messages for BCU DIDO and Swing Arm Input

You can configure the failure notification messages for Digital Input and Digital Output (DIDO) for each BCU configured in rail site view.

You can also configure general programmable input number (PIN) for swing arms. This indicates the PIN in the BCU to which the swing arm is connected.

For example: If the swing arm position input is connected to the BCU input board connectors “CA25[In+]/CA24[In-]”, then you must enter the Arm Position GP Input as “5”.

Note
- DIDO messages are applicable only for Accuload-III, Accuload-IV, Contrec 1010CB, Contrec 1010CJ, and MSC-L BCUs.
- Swing arm feature is applicable only for Contrec 1010CB and Contrec 1010CJ BCUs.
- The steps to configure BCU DIDOs for rail site view are similar to the steps to configure BCU DIDOs for truck site view.

For more information about configuring notification messages for BCU DIDOs, refer to “Configuring Notification Messages for DIDO and Swing Arm Input”.
### 6.4 Configuring Recipes

A recipe is a pure base product or a blend of two or more base products or a base product and one or more additives. You can configure the recipe numbers for each finished product.

---

**Note**

Recipe configuration is applicable only for Accuload-III, Multiload-II, MSC-L and Contrec 1010CB BCUs.

In case of Multiload-II, Component and Additive Index should be specified as per the device configuration.

The steps to configure recipes for rail site view are similar to the steps to configure recipes for truck site view.

For more information about configuring recipes, refer to “Configuring Recipes”.

---
6.5 Configuring Rail SCADA Attributes

You can define the point parameter names that are used for a particular BCU and/or virtual preset controller present in the selected location type. The configuration that is generated for each BCU and/or virtual preset is saved into the corresponding BCU table in the “SCADA Configuration” column.

You can also generate a PNT for the selected BCU and/or virtual preset controller. However, for the process point attribute type, the PNT file generated does not have any references.

To configure rail SCADA attributes

1. From the Standard Workflow Configuration Tool window, choose File > Transportation Type > RAIL.
2. Click the SCADAAttributeConfiguration tab. The window appears as follows.

3. In the Type drop-down list, click BCU to configure the SCADA attributes for BCU.
4 In the Attribute Type drop-down list, click Device. The window appears as follows.

![Configuration Window](image)

All the device attributes for the selected BCU are listed along with the details such as attribute code, attribute description, parameter name, and so on. The values for fields such as IsMandatory, DataType, IsActive, and so on are displayed by default.

5 To update the details for any attribute, select the attribute from the Attribute Code list, and then perform the following:

- Select the IsProcessPoint check box, if the values must be updated by the process parameter. If this check box is cleared, the values are updated by SCADA.
- In the Parameter Name list, type the new parameter name for the attribute.
- Select the IsReadOnly check box, if Terminal Manager must only read attribute values from the corresponding SCADA parameter or process point parameter.
6 In the **Attribute Type** drop-down list, click **TransactionPlan**. The window appears as follows.

All the transaction plan attributes for the selected BCU are listed along with the details such as attribute code, attribute description, parameter name, and so on.

7 To update the details for any attribute, select the attribute from the **Attribute Code** list, and then perform the following:

- Select the **IsProcessPoint** check box, if the values must be updated by the process parameter. If this check box is cleared, the values are updated by SCADA.

- **In the Parameter Name list**, type the new parameter name for the attribute.

- Select the **IsReadOnly** check box, if Terminal Manager must only read attribute values from the corresponding SCADA parameter or process point parameter.
In the **Attribute Type** drop-down list, click **TransactionDetails**. The window appears as follows.

All the transaction details attributes for the selected BCU are listed along with the details such as attribute code, parameter name, point name, and so on.

To update the details for any attribute, select the attribute from the **Attribute Code** list, and then perform the following:

- Select the **IsProcessPoint** check box, if the values must be updated by the process parameter. If this check box is cleared, the values are updated by SCADA.
- In the **Parameter Name** list, type the new parameter name for the attribute.
- Select the **IsReadOnly** check box, if Terminal Manager must only read attribute values from the corresponding SCADA parameter or process point parameter.

Click **Save**. The SCADA configuration details are saved. A configuration file containing the point parameter details for the selected BCU is generated and saved in the database.

Repeat the above steps to configure SCADA attributes for rail virtual preset.
6.6 Configuring Rail SCADA

You can define the point parameter names that are used for a particular BCU and/or virtual preset controller present in the selected location type. The configuration that is generated for each BCU and/or virtual preset is saved into the corresponding BCU table in the “SCADA Configuration” column.

You can also generate a PNT for the selected BCU and/or virtual preset controller. However, for the process point attribute type, the PNT file generated does not have any references.

To configure rail SCADA

1. From the Standard Workflow Configuration Tool window, choose File > Transportation Type > RAIL.
2. Click the SCADA Configuration tab.
   The window appears as follows.

   ![Standard Workflow Configuration Tool Window](image)

3. In the BCU Code drop-down list, select the code of the BCU for which you want to configure SCADA.
In the **Attribute Type** drop-down list, click **Device**. The window appears as follows.

![Attribute Configuration Window](image)

All the device attributes for the selected BCU are listed along with the details such as attribute code, attribute description, parameter name, and so on. The values for fields such as **IsMandatory**, **DataType**, **IsActive**, and so on are displayed by default.

To update the details for any attribute, select the attribute from the **Attribute Code** list, and then perform the following:

a. Select the **IsProcessPoint** check box, if the values must be updated by the process parameter. If this check box is cleared, the values are updated by SCADA.

b. In the **Parameter Name** list, type the new parameter name for the attribute.

c. In the **Point Name** list, the default point name is displayed. Type the new point name for the parameter.
6 In the **Attribute Type** drop-down list, click **TransactionPlan**. The window appears as follows.

All the transaction plan attributes for the selected BCU are listed along with the details such as attribute code, attribute description, parameter name, and so on.

7 To update the details for any attribute, select the attribute from the **Attribute Code** list, and then perform the following:

a. Select the **IsProcessPoint** check box, if the values must be updated by the process parameter. If this check box is cleared, the values are updated by SCADA.

b. In the **Parameter Name** list, type the new parameter name for the attribute.

c. In the **Point Name** list, the default point name is displayed. Type the new point name for the parameter.
8 In the **Attribute Type** drop-down list, click **TransactionDetails**. The window appears as follows.

![Attribute Type Selection](image)

All the transaction details attributes for the selected BCU are listed along with the details such as attribute code, parameter name, point name, and so on.

9 To update the details for any attribute, select the attribute from the **Attribute Code** list, and then perform the following:

   a. Select the **IsProcessPoint** check box, if the values must be updated by the process parameter. If this check box is cleared, the values are updated by SCADA.
   
   b. In the **Parameter Name** list, type the new parameter name for the attribute.
   
   c. In the **Point Name** list, the default point name is displayed. Type the new point name for the parameter.

10 Click **Save**.

The BCU SCADA configuration details are saved. A configuration file containing the point parameter details for the selected BCU is generated and saved in the database.

11 Click **Generate PNT**.

The **Save As** dialog box appears.

12 In the **File name** box, **SCADA** is displayed by default. If you want to change the name, enter a new name for the point file.
13  Click **Save**.
    A dialog box appears indicating that a point file for the BCU is generated.
14  Click **OK** to close the dialog box.
15  Repeat the steps to configure SCADA for virtual presets.
Notices

Trademarks

Experion®, PlantScape®, SafeBrowse®, TotalPlant®, and TDC 3000® are registered trademarks of Honeywell International, Inc.
OneWireless™ is a trademark of Honeywell International, Inc.

Other trademarks

Microsoft and SQL Server are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.
Trademarks that appear in this document are used only to the benefit of the trademark owner, with no intention of trademark infringement.

Third-party licenses

This product may contain or be derived from materials, including software, of third parties. The third party materials may be subject to licenses, notices, restrictions and obligations imposed by the licensor.
The licenses, notices, restrictions and obligations, if any, may be found in the materials accompanying the product, in the documents or files accompanying such third party materials, in a file named third_party_licenses on the media containing the product, or at http://www.honeywell.com/ps/thirdpartylicenses.

Documentation feedback

You can find the most up-to-date documents on the Honeywell Process Solutions support website at:
http://www.honeywellprocess.com/support
If you have comments about Honeywell Process Solutions documentation, send your feedback to:
hpsdocs@honeywell.com
Use this email address to provide feedback, or to report errors and omissions in the documentation. For immediate help with a technical problem, contact your local Honeywell Process Solutions Customer Contact Center (CCC) or Honeywell Technical Assistance Center (TAC).
How to report a security vulnerability

For the purpose of submission, a security vulnerability is defined as a software defect or weakness that can be exploited to reduce the operational or security capabilities of the software.

Honeywell investigates all reports of security vulnerabilities affecting Honeywell products and services.

To report a potential security vulnerability against any Honeywell product, please follow the instructions at:


Submit the requested information to Honeywell using one of the following methods:

Send an email to security@honeywell.com.

or

Contact your local Honeywell Process Solutions Customer Contact Center (CCC) or Honeywell Technical Assistance Center (TAC) listed in the “Support” section of this document.

Support

For support, contact your local Honeywell Process Solutions Customer Contact Center (CCC). To find your local CCC visit the website, https://www.honeywellprocess.com/en-US/contactus/customer-support-contacts/Pages/default.aspx.

Training classes

Honeywell holds technical training classes that are taught by process control systems experts. For more information about these classes, contact your Honeywell representative, or see http://www.automationcollege.com.